aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-05 11:21:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-05 13:36:44 +0200
commit49620c913578fbdd16825bc4fc2824c90dc9907f (patch)
treeee2b4d25caf028506e89700e215a6c0abca8b949
parentkde-apps/kwalletmanager: 21.08.2 version bump (diff)
downloadkde-49620c91.tar.gz
kde-49620c91.tar.bz2
kde-49620c91.zip
kde-apps/print-manager: 21.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-21.08.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
new file mode 100644
index 0000000000..cc40cf4eae
--- /dev/null
+++ b/kde-apps/print-manager/Manifest
@@ -0,0 +1 @@
+DIST print-manager-21.08.2.tar.xz 270352 BLAKE2B a1059e28212826740a5813c650c2028951d0307bbae8213d7bd0693c78af300d44bcff842346e2acce62b94f23d54c49b7b1fb77dfeb8f54b3b02245d9e8ec99 SHA512 a3b5ec03e99990cdab44d0b41715fa3c5ba8ed16f3e83f557448774dcadc5d0ddce794b77685aa8a51a20a8d1c6fcfaca0a07277aa0fd92594cf0b9d628c28af
diff --git a/kde-apps/print-manager/print-manager-21.08.2.ebuild b/kde-apps/print-manager/print-manager-21.08.2.ebuild
new file mode 100644
index 0000000000..b08f0dd9dc
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-21.08.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.84.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}