aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-21 20:00:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-21 20:25:59 +0200
commit581e5864636905d9a80057bd6023fe0c55924810 (patch)
treefce75b2ded850c58f28497e98d899d1c8273ba29
parentkde-plasma/xdg-desktop-portal-kde: 5.23.49.9999 version bump (diff)
downloadkde-581e5864636905d9a80057bd6023fe0c55924810.tar.gz
kde-581e5864636905d9a80057bd6023fe0c55924810.tar.bz2
kde-581e5864636905d9a80057bd6023fe0c55924810.zip
kde-plasma/xembed-sni-proxy: 5.23.49.9999 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.23.49.9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.23.49.9999.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.23.49.9999.ebuild
new file mode 100644
index 0000000000..8706c1098c
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.23.49.9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="plasma-workspace"
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit cmake kde.org
+
+DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-workspace/-/blob/master/xembed-sni-proxy/Readme.md"
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS=""
+
+DEPEND="
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/extra-cmake-modules-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/xembed-sni-proxy:0
+"
+
+S="${S}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.20.80-standalone.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" \
+ -i CMakeLists.txt || die "Failed to prepare CMakeLists.txt"
+}