aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-04 22:52:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-04 22:52:22 +0200
commit5ffc1fedd812317ebef44147b4b76a4ce7e65e4b (patch)
tree0c9a597862050b1fe236b91d87131bf8debb509d
parentnet-libs/libktorrent: Fix HOMEPAGE (diff)
downloadkde-5ffc1fed.tar.gz
kde-5ffc1fed.tar.bz2
kde-5ffc1fed.zip
media-sound/kaudiocreator: Add pkg_postinst log about optional RDEPENDs
Reported-by: David Zaslavsky <diazona@ellipsix.net> Gentoo-bug: 604368 Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--media-sound/kaudiocreator/kaudiocreator-9999.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/media-sound/kaudiocreator/kaudiocreator-9999.ebuild b/media-sound/kaudiocreator/kaudiocreator-9999.ebuild
index f43cf75925..44f63f1425 100644
--- a/media-sound/kaudiocreator/kaudiocreator-9999.ebuild
+++ b/media-sound/kaudiocreator/kaudiocreator-9999.ebuild
@@ -37,9 +37,27 @@ DEPEND="
media-libs/phonon[qt5]
>=media-libs/taglib-1.5
"
-
RDEPEND="${DEPEND}
$(add_kdeapps_dep audiocd-kio)
"
DOCS=( Changelog TODO )
+
+pkg_postinst() {
+ local stcnt=0
+
+ has_version media-libs/flac && stcnt=$((stcnt+1))
+ has_version media-sound/lame && stcnt=$((stcnt+1))
+ has_version media-sound/vorbis-tools && stcnt=$((stcnt+1))
+
+ if [[ ${stcnt} -lt 1 ]] ; then
+ ewarn "You you should emerge at least one of the following packages"
+ ewarn "for ${PN} to do anything useful."
+ fi
+ elog "Optional runtime dependencies:"
+ elog "FLAC - media-libs/flac"
+ elog "MP3 - media-sound/lame"
+ elog "OGG - media-sound/vorbis-tools"
+
+ kde5_pkg_postinst
+}