aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-02-05 16:21:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-02-05 16:21:00 +0100
commit6cf40c5757760efbb5abb2c28d386c6ccf9948bb (patch)
treed6200c39ed1a5bb99cc8b47a760de4df24893bc4
parentkde-frameworks: 5.31.0 version bump (diff)
downloadkde-6cf40c57.tar.gz
kde-6cf40c57.tar.bz2
kde-6cf40c57.zip
kde-apps/gwenview: Re-add pkg_postinst info about kipi-plugins,svgpart
Gentoo-bug: 608308 Package-Manager: portage-2.3.3
-rw-r--r--kde-apps/gwenview/gwenview-16.12.49.9999.ebuild12
-rw-r--r--kde-apps/gwenview/gwenview-9999.ebuild12
2 files changed, 24 insertions, 0 deletions
diff --git a/kde-apps/gwenview/gwenview-16.12.49.9999.ebuild b/kde-apps/gwenview/gwenview-16.12.49.9999.ebuild
index 258b53a51b..e85f4096a8 100644
--- a/kde-apps/gwenview/gwenview-16.12.49.9999.ebuild
+++ b/kde-apps/gwenview/gwenview-16.12.49.9999.ebuild
@@ -84,3 +84,15 @@ src_configure() {
kde5_src_configure
}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version kde-apps/svgpart:${SLOT} ; then
+ elog "For SVG support, install kde-apps/svgpart:${SLOT}"
+ fi
+
+ if use kipi && ! has_version media-plugins/kipi-plugins ; then
+ elog "Plugins for the KIPI interface can be found in media-plugins/kipi-plugins"
+ fi
+}
diff --git a/kde-apps/gwenview/gwenview-9999.ebuild b/kde-apps/gwenview/gwenview-9999.ebuild
index 483763d11f..8bac9e087f 100644
--- a/kde-apps/gwenview/gwenview-9999.ebuild
+++ b/kde-apps/gwenview/gwenview-9999.ebuild
@@ -84,3 +84,15 @@ src_configure() {
kde5_src_configure
}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version kde-apps/svgpart:${SLOT} ; then
+ elog "For SVG support, install kde-apps/svgpart:${SLOT}"
+ fi
+
+ if use kipi && ! has_version media-plugins/kipi-plugins ; then
+ elog "Plugins for the KIPI interface can be found in media-plugins/kipi-plugins"
+ fi
+}