aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-13 19:39:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-13 20:57:45 +0100
commit6d9e4e7ccc9ea68055f24c554d0e7648089c3c3f (patch)
tree9c3fed0b8e544de9a3530632dfa70fbbe6439579
parentkde-plasma/discover: Fix RDEPENDs, fix cmake options (diff)
downloadkde-6d9e4e7ccc9ea68055f24c554d0e7648089c3c3f.tar.gz
kde-6d9e4e7ccc9ea68055f24c554d0e7648089c3c3f.tar.bz2
kde-6d9e4e7ccc9ea68055f24c554d0e7648089c3c3f.zip
kde-apps/kdepim-runtime: Properly disable KDELibs4Support
Bug: https://bugs.gentoo.org/670958 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=400934 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/kdepim-runtime/files/kdepim-runtime-18.11.80-nokdelibs4support.patch55
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-18.12.49.9999.ebuild6
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild6
3 files changed, 57 insertions, 10 deletions
diff --git a/kde-apps/kdepim-runtime/files/kdepim-runtime-18.11.80-nokdelibs4support.patch b/kde-apps/kdepim-runtime/files/kdepim-runtime-18.11.80-nokdelibs4support.patch
new file mode 100644
index 0000000000..d1a916cb1d
--- /dev/null
+++ b/kde-apps/kdepim-runtime/files/kdepim-runtime-18.11.80-nokdelibs4support.patch
@@ -0,0 +1,55 @@
+From 952b572f381f965edbb0b339f7c04a4054aa262e Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 13 Nov 2018 19:23:21 +0100
+Subject: [PATCH] Move required KF5KDELibs4Support dependency to conditional
+ kolab resource
+
+Fix definitions required for build when not provided by KF5KDELibs4Support.
+
+BUG: 400934
+---
+ CMakeLists.txt | 7 +++----
+ resources/CMakeLists.txt | 1 +
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9c567ab0e..f16bc117a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -126,7 +126,6 @@ find_package(KF5DocTools ${KF5_VERSION} CONFIG REQUIRED) # pop3
+ find_package(KF5Holidays ${KF5_VERSION} CONFIG REQUIRED)
+ find_package(KF5DBusAddons ${KF5_VERSION} CONFIG REQUIRED)
+ find_package(KF5IconThemes ${KF5_VERSION} CONFIG REQUIRED)
+-find_package(KF5KDELibs4Support ${KF5_VERSION} CONFIG REQUIRED)
+
+ # KdepimLibs package
+ find_package(KF5Akonadi ${AKONADI_VERSION} CONFIG REQUIRED)
+@@ -149,10 +148,10 @@ find_package(KPimGAPI ${KGAPI_LIB_VERSION} CONFIG REQUIRED)
+
+ option(KDEPIM_RUN_ISOLATED_TESTS "Run the isolated tests." FALSE)
+
+-
+ #add_definitions( -DQT_DISABLE_DEPRECATED_BEFORE=0x060000 )
+-
+-
++# QUrl
++add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0)
++remove_definitions(-DQT_NO_CAST_FROM_ASCII)
+
+ add_subdirectory(resources)
+ add_subdirectory(agents)
+diff --git a/resources/CMakeLists.txt b/resources/CMakeLists.txt
+index 99f7dbf00..d2534cd92 100644
+--- a/resources/CMakeLists.txt
++++ b/resources/CMakeLists.txt
+@@ -43,6 +43,7 @@ add_subdirectory( dav )
+ add_subdirectory( ical )
+ add_subdirectory( imap )
+ if (Libkolabxml_FOUND)
++ find_package(KF5KDELibs4Support ${KF5_VERSION} CONFIG REQUIRED)
+ add_subdirectory( kolab )
+ endif()
+ add_subdirectory( facebook )
+--
+2.19.1
+
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-18.12.49.9999.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-18.12.49.9999.ebuild
index caf9b505ca..3650936e69 100644
--- a/kde-apps/kdepim-runtime/kdepim-runtime-18.12.49.9999.ebuild
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-18.12.49.9999.ebuild
@@ -74,8 +74,4 @@ RDEPEND="${CDEPEND}
RESTRICT+=" test"
-src_prepare() {
- kde5_src_prepare
- # We don't build kolab, so we can disable this
- punt_bogus_dep KF5 KDELibs4Support
-}
+PATCHES=( "${FILESDIR}/${PN}-18.11.80-nokdelibs4support.patch" )
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild
index caf9b505ca..3650936e69 100644
--- a/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild
@@ -74,8 +74,4 @@ RDEPEND="${CDEPEND}
RESTRICT+=" test"
-src_prepare() {
- kde5_src_prepare
- # We don't build kolab, so we can disable this
- punt_bogus_dep KF5 KDELibs4Support
-}
+PATCHES=( "${FILESDIR}/${PN}-18.11.80-nokdelibs4support.patch" )