aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-02 00:21:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-02 00:27:21 +0100
commit78e2d187d255ae5f0871b266fdf768a0558fc8f3 (patch)
tree499c850bca1e183c6a3ac296c43668a32d33e910
parentkde-apps/kdenlive: Restrict segfaulting tests once and for all (diff)
downloadkde-78e2d187.tar.gz
kde-78e2d187.tar.bz2
kde-78e2d187.zip
kde-apps/umbrello: Disable finding more packages
Bug: https://bugs.gentoo.org/708822 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/umbrello/umbrello-19.12.49.9999.ebuild6
-rw-r--r--kde-apps/umbrello/umbrello-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/kde-apps/umbrello/umbrello-19.12.49.9999.ebuild b/kde-apps/umbrello/umbrello-19.12.49.9999.ebuild
index 99da515610..ad582363fa 100644
--- a/kde-apps/umbrello/umbrello-19.12.49.9999.ebuild
+++ b/kde-apps/umbrello/umbrello-19.12.49.9999.ebuild
@@ -58,7 +58,11 @@ src_configure() {
-DBUILD_PHP_IMPORT=$(usex php)
-DBUILD_unittests=$(usex test)
)
- use test && mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_LLVM=ON )
+ use test && mycmakeargs+=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_LLVM=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Clang=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_CLANG=ON
+ )
ecm_src_configure
}
diff --git a/kde-apps/umbrello/umbrello-9999.ebuild b/kde-apps/umbrello/umbrello-9999.ebuild
index 01832f0f4a..7c3728cc5e 100644
--- a/kde-apps/umbrello/umbrello-9999.ebuild
+++ b/kde-apps/umbrello/umbrello-9999.ebuild
@@ -58,7 +58,11 @@ src_configure() {
-DBUILD_PHP_IMPORT=$(usex php)
-DBUILD_unittests=$(usex test)
)
- use test && mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_LLVM=ON )
+ use test && mycmakeargs+=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_LLVM=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Clang=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_CLANG=ON
+ )
ecm_src_configure
}