aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-19 17:06:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-19 17:39:34 +0100
commit7dff4ec8a13c85f4ba243d2b1d669cfe570b068e (patch)
treebfa786891d6ed5912bc5cfc43c07095321197ddd
parentdev-libs/kweathercore: New package (diff)
downloadkde-7dff4ec8.tar.gz
kde-7dff4ec8.tar.bz2
kde-7dff4ec8.zip
kde-misc/kweather: New package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-misc/kweather/kweather-9999.ebuild57
-rw-r--r--kde-misc/kweather/metadata.xml11
2 files changed, 68 insertions, 0 deletions
diff --git a/kde-misc/kweather/kweather-9999.ebuild b/kde-misc/kweather/kweather-9999.ebuild
new file mode 100644
index 0000000000..a34d9ec246
--- /dev/null
+++ b/kde-misc/kweather/kweather-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="false"
+KDE_ORG_CATEGORY=plasma-mobile
+KFMIN=5.88.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for retrieval of weather information including forecasts and alerts"
+HOMEPAGE="https://apps.kde.org/kweather/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KDE_ORG_CATEGORY}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="5"
+
+DEPEND="
+ dev-libs/kweathercore
+ >=dev-qt/qtcharts-${QTMIN}:5[qml]
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtpositioning-${QTMIN}:5[geoclue]
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ sed -e "/include(ECMCheckOutboundLicense)/s/^/#DONT /" \
+ -e "/ecm_check_outbound_license/s/^/#DONT /" \
+ -i CMakeLists.txt || die # avoid cmake spam about python, reusetool
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PLASMOID=ON
+ )
+ ecm_src_configure
+}
diff --git a/kde-misc/kweather/metadata.xml b/kde-misc/kweather/metadata.xml
new file mode 100644
index 0000000000..d925f24397
--- /dev/null
+++ b/kde-misc/kweather/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ </upstream>
+</pkgmetadata>