aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-19 17:14:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-19 17:49:51 +0100
commit7f7516494f10cb8383470ee69766f49b289b63e0 (patch)
tree57577ff499dc659a7657aaf31dfedcd7fec151d9
parentapp-office/merkuro: 24.02.1 version bump (diff)
downloadkde-7f7516494f10cb8383470ee69766f49b289b63e0.tar.gz
kde-7f7516494f10cb8383470ee69766f49b289b63e0.tar.bz2
kde-7f7516494f10cb8383470ee69766f49b289b63e0.zip
dev-libs/kopeninghours: 24.02.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
new file mode 100644
index 0000000000..8274ac8d2a
--- /dev/null
+++ b/dev-libs/kopeninghours/Manifest
@@ -0,0 +1 @@
+DIST kopeninghours-24.02.1.tar.xz 73344 BLAKE2B 4102d4040cea716bf1c12faca7aebf46d22636d2360c554d281f1b67ac9fa46d9b45a7d2d2a84500b2169a7639f1f892bd85899493f2bef0ebcc58f42802655a SHA512 126426103cff6974fa995356df67988dd8438e20ec2d9aa407e396d6971b2fe422e1009331d4d740da4a04eb04ac83eb2b493766b7d7af04209779ed6b9358da
diff --git a/dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild b/dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild
new file mode 100644
index 0000000000..7961724577
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-24.02.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kholidays-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}