aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-04 22:59:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-04 22:59:06 +0200
commit84a1ddb8e5fbc2d80f094549cd2af16335ab908d (patch)
tree735bf9b62a34decd91c3003a55d66737404a9076
parentkde-frameworks/plasma: 5.75.0 version bump (diff)
downloadkde-84a1ddb8.tar.gz
kde-84a1ddb8.tar.bz2
kde-84a1ddb8.zip
kde-frameworks/purpose: 5.75.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.75.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..8ab5130fb6
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-5.75.0.tar.xz 156260 BLAKE2B 907722db174faeb48bb7513a5b0e7705a4685ec3dd8667cdfe40bff3a66929d235dd832b7c335a7d6ed66ebf18ee8763ff37ace2f24950bc43548a849e5a2cd6 SHA512 21e4b6649e953e910653eb045ed485823f857acb2fa48a864ff20a716ef34471fd1e8a5d3984f7c0b7d7516757943aa2ee965a1fc40390d5def3890ccda99a2e
diff --git a/kde-frameworks/purpose/purpose-5.75.0.ebuild b/kde-frameworks/purpose/purpose-5.75.0.ebuild
new file mode 100644
index 0000000000..bc4f598c49
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.75.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth +dolphin +kaccounts"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ dolphin? ( =kde-frameworks/knotifications-${PVCUT}*:5 )
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_prepare() {
+ ecm_src_prepare
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package dolphin KF5Notifications)
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}