aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Pekkarinen <koalinux@gmail.com>2017-08-03 00:13:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-03 01:08:34 +0200
commit94f86d4d9e93668733123cad4cf43cea6f837e19 (patch)
treed96b1aa848ad02f4f0786c63c1a27cca631b1eb7
parentkde-apps/k3b: Fix USE-deps and REQUIRED_USE (diff)
downloadkde-94f86d4d.tar.gz
kde-94f86d4d.tar.bz2
kde-94f86d4d.zip
kde-plasma/plasma-workspace: Gentoo FHS script support for Wayland session
Gentoo-bug: 626746 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch40
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.10.49.9999.ebuild1
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-9999.ebuild1
3 files changed, 42 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch
new file mode 100644
index 0000000000..de56ffe236
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.10-startplasmacompositor-script.patch
@@ -0,0 +1,40 @@
+From a9b685f0dab7f21dfa3ed55011c035bab1c972d9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Pekkarinen?= <koalinux@gmail.com>
+Date: Tue, 1 Aug 2017 23:09:24 +0300
+Subject: [PATCH] Source files in /etc/plasma/{startup,shutdown}
+
+---
+ startkde/startplasmacompositor.cmake | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/startkde/startplasmacompositor.cmake b/startkde/startplasmacompositor.cmake
+index 5bcf26a..e965f19 100644
+--- a/startkde/startplasmacompositor.cmake
++++ b/startkde/startplasmacompositor.cmake
+@@ -157,6 +157,11 @@ for prefix in `echo $scriptpath`; do
+ done
+ done
+
++# Gentoo part for FHS installs
++for file in "@GENTOO_PORTAGE_EPREFIX@/etc/plasma/startup/"*.sh; do
++ test -r "${file}" && . "${file}"
++done
++
+ echo 'startplasmacompositor: Starting up...' 1>&2
+
+ # Make sure that the KDE prefix is first in XDG_DATA_DIRS and that it's set at all.
+@@ -232,6 +237,11 @@ fi
+
+ echo 'startplasmacompositor: Shutting down...' 1>&2
+
++# Gentoo part for FHS installs
++for file in "@GENTOO_PORTAGE_EPREFIX@/etc/plasma/shutdown/"*.sh; do
++ test -r "${file}" && . "${file}"
++done
++
+ unset KDE_FULL_SESSION
+ xprop -root -remove KDE_FULL_SESSION
+ unset KDE_SESSION_VERSION
+--
+2.13.0
+
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.10.49.9999.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.10.49.9999.ebuild
index cbd22c5842..ae70767907 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-5.10.49.9999.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.10.49.9999.ebuild
@@ -121,6 +121,7 @@ DEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-5.4-startkde-script.patch"
+ "${FILESDIR}/${PN}-5.10-startplasmacompositor-script.patch"
"${FILESDIR}/${PN}-5.10.4-unused-dep.patch"
)
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-9999.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-9999.ebuild
index cbd22c5842..ae70767907 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-9999.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-9999.ebuild
@@ -121,6 +121,7 @@ DEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-5.4-startkde-script.patch"
+ "${FILESDIR}/${PN}-5.10-startplasmacompositor-script.patch"
"${FILESDIR}/${PN}-5.10.4-unused-dep.patch"
)