aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 13:52:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 13:52:02 +0200
commit9ee1529db2cfe395c122c9675476784e32893a55 (patch)
tree93b8228c9a2b520215d5936be72279927b2acc5a
parentsets: Drop KDE Frameworks 5.81 (diff)
downloadkde-9ee1529db2cfe395c122c9675476784e32893a55.tar.gz
kde-9ee1529db2cfe395c122c9675476784e32893a55.tar.bz2
kde-9ee1529db2cfe395c122c9675476784e32893a55.zip
kde-plasma/plasma-firewall: Replace systemd RDEPEND w/ postinst ewarn
For administrative reasons we can't have a package pulling in systemd, this would render it essentially unsupported. Instead make clear that it will not work properly. Whoever wants to install/play around with it on openrc can now do so with that roadblock removed. Bug: https://bugs.gentoo.org/778527 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-9999.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-9999.ebuild
index 6541d6c6bf..525e35fc9c 100644
--- a/kde-plasma/plasma-firewall/plasma-firewall-9999.ebuild
+++ b/kde-plasma/plasma-firewall/plasma-firewall-9999.ebuild
@@ -35,7 +35,6 @@ DEPEND="
"
RDEPEND="${DEPEND}
${PYTHON_DEPS}
- sys-apps/systemd
|| (
net-firewall/firewalld
net-firewall/ufw
@@ -48,3 +47,12 @@ src_prepare() {
sed -e "1 s:^.*$:\#\!/usr/bin/env python3.8:" \
-i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}