aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-17 13:52:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-17 13:53:57 +0200
commitade7ab67a5dfce2ce99261fba08627e502c5c7db (patch)
tree364e6cf7d317373d9f54f205a81f2c5aaf02b45c
parentkde-apps/okular: Disable failing signunsignedfieldtest (diff)
downloadkde-ade7ab67a5dfce2ce99261fba08627e502c5c7db.tar.gz
kde-ade7ab67a5dfce2ce99261fba08627e502c5c7db.tar.bz2
kde-ade7ab67a5dfce2ce99261fba08627e502c5c7db.zip
www-client/falkon: Fix cmake w/ shiboken2 multiple python targets
Thanks-to: Olivier Huber <oli.huber@gmail.com> Closes: https://bugs.gentoo.org/832889 Package-Manager: Portage-3.0.32, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--www-client/falkon/falkon-22.07.80.ebuild13
-rw-r--r--www-client/falkon/falkon-22.08.49.9999.ebuild13
-rw-r--r--www-client/falkon/falkon-9999.ebuild13
-rw-r--r--www-client/falkon/files/falkon-22.04.3-python3.patch32
4 files changed, 59 insertions, 12 deletions
diff --git a/www-client/falkon/falkon-22.07.80.ebuild b/www-client/falkon/falkon-22.07.80.ebuild
index 84c701a5d4..0601b712d6 100644
--- a/www-client/falkon/falkon-22.07.80.ebuild
+++ b/www-client/falkon/falkon-22.07.80.ebuild
@@ -63,12 +63,12 @@ fi
RDEPEND="${COMMON_DEPEND}
>=dev-qt/qtsvg-${QTMIN}:5
"
-BDEPEND="
- >=dev-qt/linguist-tools-${QTMIN}:5
-"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+
+PATCHES=( "${FILESDIR}/${PN}-22.04.3-python3.patch" )
pkg_setup() {
- python-single-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
ecm_pkg_setup
}
@@ -83,5 +83,10 @@ src_configure() {
$(cmake_use_find_package python Python3)
-DNO_X11=$(usex !X)
)
+ use python && mycmakeargs+=(
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}" # shiboken_helpers.cmake quirk
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
ecm_src_configure
}
diff --git a/www-client/falkon/falkon-22.08.49.9999.ebuild b/www-client/falkon/falkon-22.08.49.9999.ebuild
index 18c1168945..7dd37294c1 100644
--- a/www-client/falkon/falkon-22.08.49.9999.ebuild
+++ b/www-client/falkon/falkon-22.08.49.9999.ebuild
@@ -63,12 +63,12 @@ fi
RDEPEND="${COMMON_DEPEND}
>=dev-qt/qtsvg-${QTMIN}:5
"
-BDEPEND="
- >=dev-qt/linguist-tools-${QTMIN}:5
-"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+
+PATCHES=( "${FILESDIR}/${PN}-22.04.3-python3.patch" )
pkg_setup() {
- python-single-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
ecm_pkg_setup
}
@@ -83,5 +83,10 @@ src_configure() {
$(cmake_use_find_package python Python3)
-DNO_X11=$(usex !X)
)
+ use python && mycmakeargs+=(
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}" # shiboken_helpers.cmake quirk
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
ecm_src_configure
}
diff --git a/www-client/falkon/falkon-9999.ebuild b/www-client/falkon/falkon-9999.ebuild
index 18c1168945..7dd37294c1 100644
--- a/www-client/falkon/falkon-9999.ebuild
+++ b/www-client/falkon/falkon-9999.ebuild
@@ -63,12 +63,12 @@ fi
RDEPEND="${COMMON_DEPEND}
>=dev-qt/qtsvg-${QTMIN}:5
"
-BDEPEND="
- >=dev-qt/linguist-tools-${QTMIN}:5
-"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+
+PATCHES=( "${FILESDIR}/${PN}-22.04.3-python3.patch" )
pkg_setup() {
- python-single-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
ecm_pkg_setup
}
@@ -83,5 +83,10 @@ src_configure() {
$(cmake_use_find_package python Python3)
-DNO_X11=$(usex !X)
)
+ use python && mycmakeargs+=(
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}" # shiboken_helpers.cmake quirk
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
ecm_src_configure
}
diff --git a/www-client/falkon/files/falkon-22.04.3-python3.patch b/www-client/falkon/files/falkon-22.04.3-python3.patch
new file mode 100644
index 0000000000..cd1025cbfd
--- /dev/null
+++ b/www-client/falkon/files/falkon-22.04.3-python3.patch
@@ -0,0 +1,32 @@
+From 67199ef5f470dadab17401f3aad8770ec058c111 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 17 Jul 2022 12:45:25 +0200
+Subject: [PATCH] Python3 must be found first
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 950c03adc..aa91e745e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -130,12 +130,12 @@ if (KF5Wallet_FOUND AND KF5KIO_FOUND AND KF5Crash_FOUND AND KF5CoreAddons_FOUND
+ endif()
+
+ # Optional: PySide2
++find_package(Python3 COMPONENTS Development)
+ find_package(PySide2 "2.0.0")
+ find_package(Shiboken2 "2.0.0")
+-find_package(Python3 COMPONENTS Development)
++set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ set_package_properties(PySide2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ set_package_properties(Shiboken2 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+-set_package_properties(Python3 PROPERTIES DESCRIPTION "Python plugins" TYPE OPTIONAL)
+ if (PySide2_FOUND AND Shiboken2_FOUND AND Python3_FOUND)
+ set(ENABLE_PYTHON_PLUGINS TRUE)
+ endif()
+--
+2.35.1
+