aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-11-05 02:51:56 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-11-05 02:53:02 +1100
commitc651e9fc8aaebfcfc2a8a747836f6adc079975b6 (patch)
tree52f7fdacc3697e41ebf944413e9d4d94d34c340c
parentkde-plasma/plasma-workspace: RDEPEND on kio-extras for wp thumbs (diff)
downloadkde-c651e9fc.tar.gz
kde-c651e9fc.tar.bz2
kde-c651e9fc.zip
kde-apps/kmouth: add frameworks branch
Package-Manager: portage-2.2.20.1
-rw-r--r--kde-apps/kmouth/kmouth-5.9999.ebuild32
-rw-r--r--kde-apps/kmouth/kmouth-9999.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-apps/kmouth/kmouth-5.9999.ebuild b/kde-apps/kmouth/kmouth-5.9999.ebuild
new file mode 100644
index 0000000000..53b189f0ff
--- /dev/null
+++ b/kde-apps/kmouth/kmouth-5.9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_BRANCH="frameworks"
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="KDE application that reads what you type out loud. Doesn't include a speech synthesizer"
+HOMEPAGE="https://www.kde.org/applications/utilities/kmouth/"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtspeech:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}"
diff --git a/kde-apps/kmouth/kmouth-9999.ebuild b/kde-apps/kmouth/kmouth-9999.ebuild
index ddd338f3a2..708714992c 100644
--- a/kde-apps/kmouth/kmouth-9999.ebuild
+++ b/kde-apps/kmouth/kmouth-9999.ebuild
@@ -4,6 +4,7 @@
EAPI=5
+EGIT_BRANCH="frameworks"
KDE_HANDBOOK="optional"
inherit kde4-base