aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-05-30 13:41:15 +0200
committerJohannes Huber <johu@gentoo.org>2015-05-30 13:41:15 +0200
commitcc2a85965f6be1c55f1f43fbbc4a85420186f8e4 (patch)
tree4f42b53f1bb45c249c31570cf58f971270a7a792
parent[Documentation] Remove KDE Plasma 5.2 (diff)
downloadkde-cc2a8596.tar.gz
kde-cc2a8596.tar.bz2
kde-cc2a8596.zip
[media-libs/qt-gstreamer] Add patch to fix build with dev-libs/boost-1.57, bug #550016
Thanks to David Kredba <nheghathivhistha@gmail.com> and Heiko Becker <heirecka@exherbo.org>. Package-Manager: portage-2.2.20
-rw-r--r--media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch34
-rw-r--r--media-libs/qt-gstreamer/qt-gstreamer-9999.ebuild2
2 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch b/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch
new file mode 100644
index 0000000000..a795420e3b
--- /dev/null
+++ b/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch
@@ -0,0 +1,34 @@
+From fbb9dc6e291eaa058f3ef1cd93711265bfbfd162 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Fri, 7 Nov 2014 00:11:02 +0100
+Subject: [PATCH] Workaround build failures with boost>=1.57 and moc
+
+Otherwise I get the following error message:
+'usr/include/boost/type_traits/detail/has_binary_operator.hp:50:
+Parse error at "BOOST_JOIN"'. See
+https://bugreports.qt-project.org/browse/QTBUG-22829 for details.
+
+The old workaround to define BOOST_TT_HAS_OPERATOR_HPP_INCLUDED
+doesn't seem to work here.
+---
+ src/QGlib/connect.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/QGlib/connect.cpp b/src/QGlib/connect.cpp
+index 9ff6fde..58a3367 100644
+--- a/src/QGlib/connect.cpp
++++ b/src/QGlib/connect.cpp
+@@ -21,8 +21,10 @@
+ #include <QtCore/QHash>
+ #include <QtCore/QMutex>
+ #include <boost/multi_index_container.hpp>
++#ifndef Q_MOC_RUN // See: https://bugreports.qt-project.org/browse/QTBUG-22829
+ #include <boost/multi_index/sequenced_index.hpp>
+ #include <boost/multi_index/ordered_index.hpp>
++#endif
+ #include <boost/multi_index/member.hpp>
+
+ namespace QGlib {
+--
+2.1.3
+
diff --git a/media-libs/qt-gstreamer/qt-gstreamer-9999.ebuild b/media-libs/qt-gstreamer/qt-gstreamer-9999.ebuild
index cbf031f030..7a6527cb2c 100644
--- a/media-libs/qt-gstreamer/qt-gstreamer-9999.ebuild
+++ b/media-libs/qt-gstreamer/qt-gstreamer-9999.ebuild
@@ -53,6 +53,8 @@ DEPEND="
)
"
+PATCHES=( "${FILESDIR}/${PN}-1.2.0-boost157.patch" )
+
# bug 497880
RESTRICT="test"