aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-02-28 03:00:50 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-01 22:52:01 +1100
commitdb8ab7601a5f2dfbb20156cee12148bc79d75893 (patch)
tree2a9843f1a66768c7ad03eec272a932b1483d9262
parentkde-plasma/plasma-meta: Add USE=pam for kwallet-pam RDEPEND (diff)
downloadkde-db8ab760.tar.gz
kde-db8ab760.tar.bz2
kde-db8ab760.zip
kde-plasma/kwallet-pam: Add pkg_postinst instructions, ECM to DEPENDs
Package-Manager: portage-2.2.27
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.5.49.9999.ebuild25
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-9999.ebuild32
2 files changed, 55 insertions, 2 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.5.49.9999.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.5.49.9999.ebuild
index 6b531b3f84..892584851a 100644
--- a/kde-plasma/kwallet-pam/kwallet-pam-5.5.49.9999.ebuild
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.5.49.9999.ebuild
@@ -27,3 +27,28 @@ src_configure() {
kde5_src_configure
}
+
+pkg_postinst() {
+ check_dm() {
+ if [[ -e "${ROOT}${2}" ]] && \
+ [[ -n $(egrep "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]] && \
+ [[ -n $(egrep "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]]; then
+ elog " ${1} - ${2} ...GOOD"
+ else
+ ewarn " ${1} - ${2} ...BAD"
+ fi
+ }
+ elog
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "List of things to make it work:"
+ elog "1. Use same password for login and kwallet"
+ elog "2. A display manager with support for PAM"
+ elog "3.a Have the following lines in the display manager's pam.d file:"
+ elog " -auth optional pam_kwallet5.so"
+ elog " -session optional pam_kwallet5.so auto_start"
+ elog "3.b Checking installed DMs..."
+ has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
+ has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
+ has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
+ elog
+}
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-9999.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-9999.ebuild
index 6b531b3f84..8b857d9235 100644
--- a/kde-plasma/kwallet-pam/kwallet-pam-9999.ebuild
+++ b/kde-plasma/kwallet-pam/kwallet-pam-9999.ebuild
@@ -12,11 +12,14 @@ LICENSE="LGPL-2.1"
KEYWORDS=""
IUSE=""
-DEPEND="
+COMMON_DEPEND="
dev-libs/libgcrypt:0=
virtual/pam
"
-RDEPEND="${DEPEND}
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep extra-cmake-modules)
+"
+RDEPEND="${COMMON_DEPEND}
net-misc/socat
"
@@ -27,3 +30,28 @@ src_configure() {
kde5_src_configure
}
+
+pkg_postinst() {
+ check_dm() {
+ if [[ -e "${ROOT}${2}" ]] && \
+ [[ -n $(egrep "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]] && \
+ [[ -n $(egrep "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]]; then
+ elog " ${1} - ${2} ...GOOD"
+ else
+ ewarn " ${1} - ${2} ...BAD"
+ fi
+ }
+ elog
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "List of things to make it work:"
+ elog "1. Use same password for login and kwallet"
+ elog "2. A display manager with support for PAM"
+ elog "3.a Have the following lines in the display manager's pam.d file:"
+ elog " -auth optional pam_kwallet5.so"
+ elog " -session optional pam_kwallet5.so auto_start"
+ elog "3.b Checking installed DMs..."
+ has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
+ has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
+ has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
+ elog
+}