aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 23:41:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 23:51:23 +0200
commitdbcd5c2f9cf56d201d92459200f3e3024d84bff2 (patch)
tree0a4dadb6f687f3da556a5e395191ea5ecaa1d3f1
parentkde-frameworks/networkmanager-qt: Tarball respun (diff)
downloadkde-dbcd5c2f.tar.gz
kde-dbcd5c2f.tar.bz2
kde-dbcd5c2f.zip
kde-apps/cantor: Switch to python3_{5,6,7}
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/cantor/cantor-19.04.49.9999.ebuild24
-rw-r--r--kde-apps/cantor/cantor-9999.ebuild24
2 files changed, 18 insertions, 30 deletions
diff --git a/kde-apps/cantor/cantor-19.04.49.9999.ebuild b/kde-apps/cantor/cantor-19.04.49.9999.ebuild
index 601738f64c..8a32077f6f 100644
--- a/kde-apps/cantor/cantor-19.04.49.9999.ebuild
+++ b/kde-apps/cantor/cantor-19.04.49.9999.ebuild
@@ -5,9 +5,8 @@ EAPI=7
KDE_HANDBOOK="forceoptional"
KDE_TEST="forceoptional"
-PYTHON_COMPAT=( python2_7 )
-# FIXME: PYTHON_COMPAT=( python3_{5,6,7} )
-inherit kde5 python-r1
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit kde5 python-single-r1
DESCRIPTION="Interface for doing mathematics and scientific computing"
HOMEPAGE="https://kde.org/applications/education/cantor https://edu.kde.org/cantor/"
@@ -17,7 +16,6 @@ IUSE="+analitza julia lua markdown postscript python qalculate R"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
-# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
DEPEND="
$(add_frameworks_dep karchive)
$(add_frameworks_dep kcompletion)
@@ -51,7 +49,10 @@ DEPEND="
sci-libs/libqalculate:=
)
postscript? ( app-text/libspectre )
- python? ( ${PYTHON_DEPS} )
+ python? (
+ ${PYTHON_DEPS}
+ $(add_qt_dep qtdbus)
+ )
R? ( dev-lang/R )
"
RDEPEND="${DEPEND}"
@@ -81,28 +82,21 @@ pkg_pretend() {
}
pkg_setup() {
- use python && python_setup
+ use python && python-single-r1_pkg_setup
kde5_pkg_setup
}
-src_prepare() {
- kde5_src_prepare
-
- # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
- sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
- -i src/backends/CMakeLists.txt || die
-}
-
src_configure() {
use julia && addpredict /proc/self/mem # bug 602894
local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonLibs=ON
$(cmake-utils_use_find_package analitza Analitza5)
$(cmake-utils_use_find_package julia Julia)
$(cmake-utils_use_find_package lua LuaJIT)
$(cmake-utils_use_find_package markdown Discount)
$(cmake-utils_use_find_package postscript LibSpectre)
- $(cmake-utils_use_find_package python PythonLibs)
+ $(cmake-utils_use_find_package python PythonLibs3)
$(cmake-utils_use_find_package qalculate Qalculate)
$(cmake-utils_use_find_package R R)
)
diff --git a/kde-apps/cantor/cantor-9999.ebuild b/kde-apps/cantor/cantor-9999.ebuild
index 601738f64c..8a32077f6f 100644
--- a/kde-apps/cantor/cantor-9999.ebuild
+++ b/kde-apps/cantor/cantor-9999.ebuild
@@ -5,9 +5,8 @@ EAPI=7
KDE_HANDBOOK="forceoptional"
KDE_TEST="forceoptional"
-PYTHON_COMPAT=( python2_7 )
-# FIXME: PYTHON_COMPAT=( python3_{5,6,7} )
-inherit kde5 python-r1
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit kde5 python-single-r1
DESCRIPTION="Interface for doing mathematics and scientific computing"
HOMEPAGE="https://kde.org/applications/education/cantor https://edu.kde.org/cantor/"
@@ -17,7 +16,6 @@ IUSE="+analitza julia lua markdown postscript python qalculate R"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
-# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
DEPEND="
$(add_frameworks_dep karchive)
$(add_frameworks_dep kcompletion)
@@ -51,7 +49,10 @@ DEPEND="
sci-libs/libqalculate:=
)
postscript? ( app-text/libspectre )
- python? ( ${PYTHON_DEPS} )
+ python? (
+ ${PYTHON_DEPS}
+ $(add_qt_dep qtdbus)
+ )
R? ( dev-lang/R )
"
RDEPEND="${DEPEND}"
@@ -81,28 +82,21 @@ pkg_pretend() {
}
pkg_setup() {
- use python && python_setup
+ use python && python-single-r1_pkg_setup
kde5_pkg_setup
}
-src_prepare() {
- kde5_src_prepare
-
- # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
- sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
- -i src/backends/CMakeLists.txt || die
-}
-
src_configure() {
use julia && addpredict /proc/self/mem # bug 602894
local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonLibs=ON
$(cmake-utils_use_find_package analitza Analitza5)
$(cmake-utils_use_find_package julia Julia)
$(cmake-utils_use_find_package lua LuaJIT)
$(cmake-utils_use_find_package markdown Discount)
$(cmake-utils_use_find_package postscript LibSpectre)
- $(cmake-utils_use_find_package python PythonLibs)
+ $(cmake-utils_use_find_package python PythonLibs3)
$(cmake-utils_use_find_package qalculate Qalculate)
$(cmake-utils_use_find_package R R)
)