aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-04 20:00:27 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-04 20:00:27 +0200
commitdd426aa8d27736927c4fb81824eff50f08b5fa72 (patch)
treed34f7df9d1c0cf99ebf0baa56a96f430783fde52
parentkde-apps/kio-extras: Update dependencies (diff)
downloadkde-dd426aa8.tar.gz
kde-dd426aa8.tar.bz2
kde-dd426aa8.zip
dev-libs/grantlee: Fix slot patch
Syncing latest changes including working patch from gentoo main tree. Reported-by: Sput on irc in #gentoo-kde @ freenode Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/grantlee/files/grantlee-5.1.0-slot.patch (renamed from dev-libs/grantlee/files/grantlee-slot.patch)17
-rw-r--r--dev-libs/grantlee/grantlee-9999.ebuild5
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-libs/grantlee/files/grantlee-slot.patch b/dev-libs/grantlee/files/grantlee-5.1.0-slot.patch
index 5c384b7bb0..5b0d61d5c1 100644
--- a/dev-libs/grantlee/files/grantlee-slot.patch
+++ b/dev-libs/grantlee/files/grantlee-5.1.0-slot.patch
@@ -1,7 +1,7 @@
Install headers to a custom location to permit slotting with Qt4 version.
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dca14ec..d25656d 100644
+index 1324566..f98d5da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '6
@@ -14,10 +14,10 @@ index dca14ec..d25656d 100644
# set up RPATH/install_name_dir
diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
-index 741fe65..20179fc 100644
+index dad2ef8..434d163 100644
--- a/templates/lib/CMakeLists.txt
+++ b/templates/lib/CMakeLists.txt
-@@ -81,6 +81,7 @@ if (Qt5Script_FOUND)
+@@ -107,6 +107,7 @@ if (Qt5Script_FOUND)
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
@@ -26,14 +26,13 @@ index 741fe65..20179fc 100644
LINK_PRIVATE Qt5::Script
)
diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
-index 4c94203..e203539 100644
+index 557d262..d2dbaa1 100644
--- a/textdocument/lib/CMakeLists.txt
+++ b/textdocument/lib/CMakeLists.txt
-@@ -24,7 +24,7 @@ add_library(Grantlee_TextDocument SHARED
- generate_export_header(Grantlee_TextDocument)
- add_library(Grantlee::TextDocument ALIAS Grantlee_TextDocument)
- set_property(TARGET Grantlee_TextDocument PROPERTY EXPORT_NAME TextDocument)
--
+@@ -42,6 +42,7 @@ if (CMAKE_GENERATOR MATCHES "Visual Studio")
+ )
+ endforeach()
+ endif()
+target_include_directories(Grantlee_TextDocument INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
target_link_libraries(Grantlee_TextDocument
diff --git a/dev-libs/grantlee/grantlee-9999.ebuild b/dev-libs/grantlee/grantlee-9999.ebuild
index 0283a47eba..5ac89efbe0 100644
--- a/dev-libs/grantlee/grantlee-9999.ebuild
+++ b/dev-libs/grantlee/grantlee-9999.ebuild
@@ -4,6 +4,7 @@
EAPI=6
+CMAKE_MIN_VERSION="3.1"
VIRTUALX_REQUIRED="test"
inherit cmake-utils virtualx git-r3
@@ -11,7 +12,7 @@ DESCRIPTION="C++ string template engine based on the Django template system"
HOMEPAGE="https://github.com/steveire/grantlee"
EGIT_REPO_URI=( "https://github.com/steveire/${PN}" )
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
SLOT="5"
KEYWORDS=""
IUSE="debug doc test"
@@ -30,7 +31,7 @@ DOCS=( AUTHORS CHANGELOG README.md )
PATCHES=(
"${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
- "${FILESDIR}/${PN}-slot.patch"
+ "${FILESDIR}/${PN}-5.1.0-slot.patch"
)
src_configure() {