aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-12-29 17:51:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-12-29 19:44:22 +0100
commite960c044f7bcb8f0e9bc16e14cf19a394a456ee2 (patch)
treefa544c3052684da32896deb7457a8960f144ea2f
parentecm.eclass: Introduce ecm_punt_kf_module and ecm_punt_qt_module (diff)
downloadkde-e960c044.tar.gz
kde-e960c044.tar.bz2
kde-e960c044.zip
ecm.eclass: Use new ecm_punt_kf_module/ecm_punt_qt_module internally
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--eclass/ecm.eclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/eclass/ecm.eclass b/eclass/ecm.eclass
index 9903eeef3e..e173139565 100644
--- a/eclass/ecm.eclass
+++ b/eclass/ecm.eclass
@@ -429,7 +429,7 @@ ecm_src_prepare() {
cmake_comment_add_subdirectory ${ECM_HANDBOOK_DIR}
if [[ ${ECM_HANDBOOK} = forceoptional ]] ; then
- ecm_punt_bogus_dep KF5 DocTools
+ ecm_punt_kf_module DocTools
sed -i -e "/kdoctools_install/I s/^/#DONT/" CMakeLists.txt || die
fi
fi
@@ -454,18 +454,18 @@ ecm_src_prepare() {
# only build unit tests when required
if ! { in_iuse test && use test; } ; then
if [[ ${ECM_TEST} = forceoptional ]] ; then
- ecm_punt_bogus_dep Qt5 Test
+ ecm_punt_qt_module Test
# if forceoptional, also cover non-kde categories
cmake_comment_add_subdirectory autotests test tests
elif [[ ${ECM_TEST} = forceoptional-recursive ]] ; then
- ecm_punt_bogus_dep Qt5 Test
+ ecm_punt_qt_module Test
local f pf="${T}/${P}"-tests-optional.patch
touch ${pf} || die "Failed to touch patch file"
for f in $(find . -type f -name "CMakeLists.txt" -exec \
grep -li "^\s*add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)" {} \;); do
cp ${f} ${f}.old || die "Failed to prepare patch origfile"
pushd ${f%/*} > /dev/null || die
- ecm_punt_bogus_dep Qt5 Test
+ ecm_punt_qt_module Test
sed -i CMakeLists.txt -e \
"/^#/! s/add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)/if(BUILD_TESTING)\n&\nendif()/I" \
|| die