aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-27 21:32:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-28 00:21:35 +0100
commitf0925460daa14b611b085709a55ab39eeac82378 (patch)
treeac4cf5030d77d3e7939bec273d36196bb0e3e086
parentkde-frameworks/knewstuff: add 9999 (diff)
downloadkde-f0925460.tar.gz
kde-f0925460.tar.bz2
kde-f0925460.zip
kde-frameworks/kparts: add 9999
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kparts/kparts-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/kparts/kparts-9999.ebuild b/kde-frameworks/kparts/kparts-9999.ebuild
new file mode 100644
index 0000000000..180cd7ae92
--- /dev/null
+++ b/kde-frameworks/kparts/kparts-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework providing elaborate user-interface components"
+
+LICENSE="LGPL-2+"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets,xml]
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kjobwidgets-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+ =kde-frameworks/kxmlgui-${PVCUT}*:6
+"
+DEPEND="${RDEPEND}"