aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-20 17:19:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-20 20:15:56 +0100
commitf49368297e01d6a9ebc92d81a7713259b3f25c69 (patch)
tree458cf0a16c1080faa18481a1b5cd6549833917e2
parentprofiles: Remove leftover package.mask (diff)
downloadkde-f49368297e01d6a9ebc92d81a7713259b3f25c69.tar.gz
kde-f49368297e01d6a9ebc92d81a7713259b3f25c69.tar.bz2
kde-f49368297e01d6a9ebc92d81a7713259b3f25c69.zip
kde-frameworks/kconfig: Add missing dependency
Upstream commit 8579ec54838b7188ed016f7adb4a69bbf2e39712 Reported-by: Jochen Schlick <josch09@gmail.com> Closes: https://bugs.gentoo.org/675880 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kconfig/kconfig-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/kde-frameworks/kconfig/kconfig-9999.ebuild b/kde-frameworks/kconfig/kconfig-9999.ebuild
index dd3cd601e0..9805bef308 100644
--- a/kde-frameworks/kconfig/kconfig-9999.ebuild
+++ b/kde-frameworks/kconfig/kconfig-9999.ebuild
@@ -9,11 +9,12 @@ inherit kde5
DESCRIPTION="Framework for reading and writing configuration"
LICENSE="LGPL-2+"
KEYWORDS=""
-IUSE="nls"
+IUSE="dbus nls"
RDEPEND="
$(add_qt_dep qtgui)
$(add_qt_dep qtxml)
+ dbus? ( $(add_qt_dep qtdbus) )
"
DEPEND="${RDEPEND}
nls? ( $(add_qt_dep linguist-tools) )
@@ -24,3 +25,10 @@ DEPEND="${RDEPEND}
RESTRICT+=" test"
DOCS=( DESIGN docs/DESIGN.kconfig docs/options.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKCONFIG_USE_DBUS=$(usex dbus)
+ )
+ kde5_src_configure
+}