aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-29 09:15:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-01 09:59:49 +0200
commitff785331a7f8722f2ebdb9fc7cdc734ad8943b13 (patch)
tree59e8c9718c382de429ba1ff1be67cc134446ca57
parentkde-apps/*: Sync live ebuilds (diff)
downloadkde-ff785331.tar.gz
kde-ff785331.tar.bz2
kde-ff785331.zip
kde-apps/ktouch: Fix build with USE -X
Add IUSE metadata description Upstream commit d290b2a51d5aa4694ec746ce5cc9456977efde71 Bug: https://bugs.gentoo.org/813450 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/ktouch/files/ktouch-22.04.3-without_x11.patch97
-rw-r--r--kde-apps/ktouch/ktouch-22.07.80.ebuild5
-rw-r--r--kde-apps/ktouch/ktouch-22.08.49.9999.ebuild5
-rw-r--r--kde-apps/ktouch/ktouch-9999.ebuild3
-rw-r--r--kde-apps/ktouch/metadata.xml3
5 files changed, 107 insertions, 6 deletions
diff --git a/kde-apps/ktouch/files/ktouch-22.04.3-without_x11.patch b/kde-apps/ktouch/files/ktouch-22.04.3-without_x11.patch
new file mode 100644
index 0000000000..dbfc2d9498
--- /dev/null
+++ b/kde-apps/ktouch/files/ktouch-22.04.3-without_x11.patch
@@ -0,0 +1,97 @@
+From d290b2a51d5aa4694ec746ce5cc9456977efde71 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 31 Jul 2022 16:17:30 +0200
+Subject: [PATCH] Add CMake option to build WITHOUT_X11
+
+We want to be able to build without X11 support even if some of the used
+libraries may not work w/o X11 themselves yet or need to be built with
+X11 support for other reverse dependencies.
+
+KTOUCH_BUILD_WITH_X11 already exists and is set automagically so far,
+but using -DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any
+dependencies list X11 as required in their cmake config.
+
+Introducing this option means there is no behavior change by default,
+cmake will just skip finding X11 or adding unwanted features if the
+option is enabled.
+
+- Move the checks to root CMakeLists.txt
+- Move finding Qt5X11Extras behind "NOT WITHOUT_X11" too
+- x11_helper is conditional on KTOUCH_BUILD_WITH_X11
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 18 +++++++++++++++---
+ src/CMakeLists.txt | 13 +------------
+ 2 files changed, 16 insertions(+), 15 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9ec74a5..a05231b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -39,9 +39,6 @@ find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED COMPONENTS
+ Xml
+ XmlPatterns
+ )
+-if (QT_MAJOR_VERSION STREQUAL "5")
+-find_package(Qt5X11Extras)
+-endif()
+ find_package(Qt${QT_MAJOR_VERSION} CONFIG QUIET OPTIONAL_COMPONENTS QuickCompiler)
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+@@ -62,6 +59,21 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+
+
+ option(COMPILE_QML "Precompile QML code" OFF)
++option(WITHOUT_X11 "Build without X11 Keyboard Layout Detection (skips finding X11)" OFF)
++
++if (NOT WITHOUT_X11)
++ find_package(X11)
++ find_package(XCB OPTIONAL_COMPONENTS XCB XKB)
++ if (QT_MAJOR_VERSION STREQUAL "5")
++ find_package(Qt5X11Extras ${QT_MIN_VERSION} CONFIG)
++ endif()
++
++ if (Qt5X11Extras_FOUND AND X11_FOUND AND X11_Xkbfile_FOUND AND X11_Xkb_FOUND AND XCB_FOUND AND XCB_XKB_FOUND)
++ set(KTOUCH_BUILD_WITH_X11 TRUE)
++ endif()
++
++ add_feature_info ("Keyboard Layout Detection" KTOUCH_BUILD_WITH_X11 "needs Qt5X11Extras, libX11, libxkb, libxkbfile, libxcb, and libxcb-xkb")
++endif()
+
+ # enable QML debugging for debug builds
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DQT_QML_DEBUG")
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index cb6f3f5..9dd2a5f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -4,15 +4,6 @@ ecm_setup_version(${RELEASE_SERVICE_VERSION}
+ PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/KTouchConfigVersion.cmake"
+ )
+
+-find_package(X11)
+-find_package(XCB OPTIONAL_COMPONENTS XCB XKB)
+-
+-if (Qt5X11Extras_FOUND AND X11_FOUND AND X11_Xkbfile_FOUND AND X11_Xkb_FOUND AND XCB_FOUND AND XCB_XKB_FOUND)
+- set(KTOUCH_BUILD_WITH_X11 TRUE)
+-endif()
+-
+-add_feature_info ("Keyboard Layout Detection" KTOUCH_BUILD_WITH_X11 "needs Qt5X11Extras, libX11, libxkb, libxkbfile, libxcb, and libxcb-xkb")
+-
+ ecm_optional_add_subdirectory(schemata)
+
+ # set include directories
+@@ -137,9 +128,7 @@ set(ktouch_SRCS
+ undocommands/coursecommands.cpp
+ undocommands/coursecommands.h
+ undocommands/keyboardlayoutcommands.cpp
+- undocommands/keyboardlayoutcommands.h
+- x11_helper.cpp
+- x11_helper.h)
++ undocommands/keyboardlayoutcommands.h)
+
+ qt_add_resources(ktouch_imgs_SRCS images/images.qrc)
+
+--
+GitLab
+
diff --git a/kde-apps/ktouch/ktouch-22.07.80.ebuild b/kde-apps/ktouch/ktouch-22.07.80.ebuild
index c443f79e4b..bb4128c70c 100644
--- a/kde-apps/ktouch/ktouch-22.07.80.ebuild
+++ b/kde-apps/ktouch/ktouch-22.07.80.ebuild
@@ -54,11 +54,12 @@ RDEPEND="${COMMON_DEPEND}
>=kde-apps/kqtquickcharts-${PVCUT}:5
"
+PATCHES=( "${FILESDIR}/${PN}-22.04.3-without_x11.patch" )
+
src_configure() {
local mycmakeargs=(
-DCOMPILE_QML=OFF
- $(cmake_use_find_package X X11)
- $(cmake_use_find_package X Qt5X11Extras)
+ -DWITHOUT_X11=$(usex !X)
)
ecm_src_configure
}
diff --git a/kde-apps/ktouch/ktouch-22.08.49.9999.ebuild b/kde-apps/ktouch/ktouch-22.08.49.9999.ebuild
index f77fc49426..ee3251fe42 100644
--- a/kde-apps/ktouch/ktouch-22.08.49.9999.ebuild
+++ b/kde-apps/ktouch/ktouch-22.08.49.9999.ebuild
@@ -54,11 +54,12 @@ RDEPEND="${COMMON_DEPEND}
>=kde-apps/kqtquickcharts-${PVCUT}:5
"
+PATCHES=( "${FILESDIR}/${PN}-22.04.3-without_x11.patch" )
+
src_configure() {
local mycmakeargs=(
-DCOMPILE_QML=OFF
- $(cmake_use_find_package X X11)
- $(cmake_use_find_package X Qt5X11Extras)
+ -DWITHOUT_X11=$(usex !X)
)
ecm_src_configure
}
diff --git a/kde-apps/ktouch/ktouch-9999.ebuild b/kde-apps/ktouch/ktouch-9999.ebuild
index f77fc49426..93c6bad8de 100644
--- a/kde-apps/ktouch/ktouch-9999.ebuild
+++ b/kde-apps/ktouch/ktouch-9999.ebuild
@@ -57,8 +57,7 @@ RDEPEND="${COMMON_DEPEND}
src_configure() {
local mycmakeargs=(
-DCOMPILE_QML=OFF
- $(cmake_use_find_package X X11)
- $(cmake_use_find_package X Qt5X11Extras)
+ -DWITHOUT_X11=$(usex !X)
)
ecm_src_configure
}
diff --git a/kde-apps/ktouch/metadata.xml b/kde-apps/ktouch/metadata.xml
index d925f24397..6e812b0dfa 100644
--- a/kde-apps/ktouch/metadata.xml
+++ b/kde-apps/ktouch/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<bugs-to>https://bugs.kde.org/</bugs-to>
</upstream>
+ <use>
+ <flag name="X">Enable support for X11 Keyboard Layout Detection</flag>
+ </use>
</pkgmetadata>