aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-05 21:43:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-05 21:46:39 +0100
commit18888aa174bf206487c4079e57f488d871de11e6 (patch)
tree0c1d9f71a88af102410aef216329aecfe1765b8f /Documentation/maintainers
parentDocumentation: lib.sh: Fix get_main_tree_keyword() (diff)
downloadkde-18888aa174bf206487c4079e57f488d871de11e6.tar.gz
kde-18888aa174bf206487c4079e57f488d871de11e6.tar.bz2
kde-18888aa174bf206487c4079e57f488d871de11e6.zip
Documentation: bump-from-set.sh: Fix get_main_tree_keyword()
Sometimes ^KEYWORDS does not match. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'Documentation/maintainers')
-rwxr-xr-xDocumentation/maintainers/bump-from-set.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/Documentation/maintainers/bump-from-set.sh b/Documentation/maintainers/bump-from-set.sh
index b849c11dfa..4d44f42017 100755
--- a/Documentation/maintainers/bump-from-set.sh
+++ b/Documentation/maintainers/bump-from-set.sh
@@ -27,7 +27,7 @@ get_main_tree_keyword() {
local portdir="$(portageq get_repo_path / gentoo)"
local cp="${1}"
if [[ -e ${portdir}/${cp} ]] ; then
- echo $(sed -ne 's/^KEYWORDS="\(.*\)"/\1/p' "$(ls ${portdir}/${cp}/*.ebuild | sort | tail -n 1)")
+ echo $(sed -ne 's/^\s*KEYWORDS="\(.*\)"/\1/p' "$(ls ${portdir}/${cp}/*.ebuild | sort | tail -n 1)")
else
echo "~amd64 ~x86"
fi