aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-11 22:54:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-11 23:43:49 +0200
commite7d827be7d5bc5a56e97de418d1211afb64d10ef (patch)
treed696722a0d26150f13da1a9c88351cfccd6ff0a1 /app-text/kbibtex
parentapp-text/kbibtex: Add USE=zotero and missing DEPENDs (diff)
downloadkde-e7d827be7d5bc5a56e97de418d1211afb64d10ef.tar.gz
kde-e7d827be7d5bc5a56e97de418d1211afb64d10ef.tar.bz2
kde-e7d827be7d5bc5a56e97de418d1211afb64d10ef.zip
app-text/kbibtex: Rebase qtoauth patches
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'app-text/kbibtex')
-rw-r--r--app-text/kbibtex/files/kbibtex-part-revert-reenable-qtoauth.patch51
-rw-r--r--app-text/kbibtex/files/kbibtex-revert-removing-qtoauth.patch112
-rw-r--r--app-text/kbibtex/files/kbibtex-system-qtoauth.patch115
-rw-r--r--app-text/kbibtex/kbibtex-9999.ebuild5
4 files changed, 116 insertions, 167 deletions
diff --git a/app-text/kbibtex/files/kbibtex-part-revert-reenable-qtoauth.patch b/app-text/kbibtex/files/kbibtex-part-revert-reenable-qtoauth.patch
deleted file mode 100644
index ce095c6698..0000000000
--- a/app-text/kbibtex/files/kbibtex-part-revert-reenable-qtoauth.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 84f84747649237afcf9bd7465ba85fafd6bbc240 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 24 Jan 2016 13:16:54 +0100
-Subject: [PATCH 2/2] Partially revert "Re-enabling code for QtOAuth"
-
-This partially reverts commit 7b6937326ba2a4e4072692add38a4abd28bd0cd4
-so that kbibtex is using system-qoauth instead of bundled one.
-
-REVIEW: 129927
----
- src/networking/CMakeLists.txt | 3 ---
- src/networking/zotero/oauthwizard.cpp | 2 +-
- 2 files changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/src/networking/CMakeLists.txt b/src/networking/CMakeLists.txt
-index 27507b3a..4f3d03bc 100644
---- a/src/networking/CMakeLists.txt
-+++ b/src/networking/CMakeLists.txt
-@@ -42,8 +42,6 @@ if(NOT WIN32)
- zotero/groups.cpp
- zotero/tags.cpp
- zotero/tagmodel.cpp
-- # QOAuth for Qt5 from Git
-- ../3rdparty/qoauth/src/interface.cpp
- )
- endif(NOT WIN32)
-
-@@ -88,7 +86,6 @@ if(UNITY_BUILD)
- endif(UNITY_BUILD)
-
- include_directories(
-- ${CMAKE_SOURCE_DIR}/src/3rdparty/qoauth/include
- ${CMAKE_BINARY_DIR}/src/config
- ${CMAKE_SOURCE_DIR}/src/config
- ${CMAKE_BINARY_DIR}/src/data
-diff --git a/src/networking/zotero/oauthwizard.cpp b/src/networking/zotero/oauthwizard.cpp
-index 1d9129ee..91ff23bf 100644
---- a/src/networking/zotero/oauthwizard.cpp
-+++ b/src/networking/zotero/oauthwizard.cpp
-@@ -34,7 +34,7 @@
- #include "internalnetworkaccessmanager.h"
- #include "logging_networking.h"
-
--#include <QtOAuth>
-+#include <QtOAuth/QtOAuth>
-
- using namespace Zotero;
-
---
-2.12.2
-
diff --git a/app-text/kbibtex/files/kbibtex-revert-removing-qtoauth.patch b/app-text/kbibtex/files/kbibtex-revert-removing-qtoauth.patch
deleted file mode 100644
index 3e0195b485..0000000000
--- a/app-text/kbibtex/files/kbibtex-revert-removing-qtoauth.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-From 0ecdc46fbf9cdab24be92e785ec59b2338634cb1 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 24 Jan 2016 13:04:26 +0100
-Subject: [PATCH 1/2] Revert "Removing references to QtOAuth and Qca-Qt5"
-
-This reverts commit ff4b966f13b1b8da8471f92f44751b58012a53e8.
-
-REVIEW: 129927
----
- CMakeLists.txt | 20 ++++++++++++++++++++
- src/networking/CMakeLists.txt | 33 +++++++++++++++++++++++++++++++--
- 2 files changed, 51 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f8620185..b22b5ef8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -152,6 +152,26 @@ endif(
- )
-
- find_package(
-+ QtOAuth
-+)
-+if(
-+ QTOAUTH_FOUND
-+)
-+ add_definitions(
-+ -DHAVE_QTOAUTH
-+ )
-+else(
-+ QTOAUTH_FOUND
-+)
-+ message(
-+ STATUS
-+ "No QtOAuth installed, disabling Zotero OAuth wizard"
-+ )
-+endif(
-+ QTOAUTH_FOUND
-+)
-+
-+find_package(
- Qca-qt5 "2.1.0"
- REQUIRED
- )
-diff --git a/src/networking/CMakeLists.txt b/src/networking/CMakeLists.txt
-index f99236c1..27507b3a 100644
---- a/src/networking/CMakeLists.txt
-+++ b/src/networking/CMakeLists.txt
-@@ -40,7 +40,6 @@ if(NOT WIN32)
- zotero/collection.cpp
- zotero/items.cpp
- zotero/groups.cpp
-- zotero/oauthwizard.cpp
- zotero/tags.cpp
- zotero/tagmodel.cpp
- # QOAuth for Qt5 from Git
-@@ -79,7 +78,6 @@ set(
- zotero/tagmodel.h
- zotero/items.h
- zotero/api.h
-- zotero/oauthwizard.h
- associatedfiles.h
- findpdf.h
- internalnetworkaccessmanager.h
-@@ -102,6 +100,26 @@ include_directories(
- ${CMAKE_SOURCE_DIR}/src/global
- )
-
-+if(
-+ QTOAUTH_FOUND
-+)
-+ include_directories(
-+ ${QTOAUTH_INCLUDE_DIR}
-+ )
-+ set(
-+ kbibtexnetworking_HDRS
-+ ${kbibtexnetworking_HDRS}
-+ zotero/oauthwizard.h
-+ )
-+ set(
-+ kbibtexnetworking_LIB_SRCS
-+ ${kbibtexnetworking_LIB_SRCS}
-+ zotero/oauthwizard.cpp
-+ )
-+endif(
-+ QTOAUTH_FOUND
-+)
-+
- add_library(
- kbibtexnetworking
- SHARED
-@@ -128,6 +146,17 @@ target_link_libraries(
- ${Poppler_Qt5_LIBRARY}
- )
-
-+if(
-+ QTOAUTH_FOUND
-+)
-+ target_link_libraries(
-+ kbibtexnetworking
-+ ${QTOAUTH_LIBRARY}
-+ )
-+endif(
-+ QTOAUTH_FOUND
-+)
-+
- set_target_properties(
- kbibtexnetworking
- PROPERTIES
---
-2.12.2
-
diff --git a/app-text/kbibtex/files/kbibtex-system-qtoauth.patch b/app-text/kbibtex/files/kbibtex-system-qtoauth.patch
new file mode 100644
index 0000000000..b582273743
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-system-qtoauth.patch
@@ -0,0 +1,115 @@
+commit d5742d770702b60f375139abb4df6f550682dbe8
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun Jan 24 13:04:26 2016 +0100
+
+ Re-enable system QtOAuth
+
+ This reverts commit ff4b966f13b1b8da8471f92f44751b58012a53e8 and
+ partially reverts commit 7b6937326ba2a4e4072692add38a4abd28bd0cd4
+ so that kbibtex is using system-qoauth instead of bundled one.
+
+ REVIEW: 129927
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fc73a28c..f5db0bb2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -165,6 +165,26 @@ endif(
+ )
+
+ find_package(
++ QtOAuth
++)
++if(
++ QTOAUTH_FOUND
++)
++ add_definitions(
++ -DHAVE_QTOAUTH
++ )
++else(
++ QTOAUTH_FOUND
++)
++ message(
++ STATUS
++ "No QtOAuth installed, disabling Zotero OAuth wizard"
++ )
++endif(
++ QTOAUTH_FOUND
++)
++
++find_package(
+ Qca-qt5 "2.1.0"
+ )
+ if (Qca-qt5_FOUND)
+diff --git a/src/networking/CMakeLists.txt b/src/networking/CMakeLists.txt
+index bd16f61e..2e3c4d58 100644
+--- a/src/networking/CMakeLists.txt
++++ b/src/networking/CMakeLists.txt
+@@ -40,12 +40,23 @@ if(BUILD_ZOTERO)
+ zotero/collection.cpp
+ zotero/items.cpp
+ zotero/groups.cpp
+- zotero/oauthwizard.cpp
+ zotero/tags.cpp
+ zotero/tagmodel.cpp
+- # QOAuth for Qt5 from Git
+- ../3rdparty/qoauth/src/interface.cpp
++ )
++ if(
++ QTOAUTH_FOUND
++ )
++ include_directories(
++ ${QTOAUTH_INCLUDE_DIR}
++ )
++ list(
++ APPEND
++ kbibtexnetworking_LIB_SRCS
++ zotero/oauthwizard.cpp
+ )
++ endif(
++ QTOAUTH_FOUND
++ )
+ endif(BUILD_ZOTERO)
+
+ set(
+@@ -90,7 +101,6 @@ if(UNITY_BUILD)
+ endif(UNITY_BUILD)
+
+ include_directories(
+- ${CMAKE_SOURCE_DIR}/src/3rdparty/qoauth/include
+ ${CMAKE_BINARY_DIR}/src/config
+ ${CMAKE_SOURCE_DIR}/src/config
+ ${CMAKE_BINARY_DIR}/src/data
+@@ -132,9 +142,18 @@ if(BUILD_ZOTERO)
+ kbibtexnetworking
+ qca-qt5
+ )
++ if(
++ QTOAUTH_FOUND
++ )
++ target_link_libraries(
++ kbibtexnetworking
++ ${QTOAUTH_LIBRARY}
++ )
++ endif(
++ QTOAUTH_FOUND
++ )
+ endif(BUILD_ZOTERO)
+
+-
+ set_target_properties(
+ kbibtexnetworking
+ PROPERTIES
+diff --git a/src/networking/zotero/oauthwizard.cpp b/src/networking/zotero/oauthwizard.cpp
+index aca03049..7d97886c 100644
+--- a/src/networking/zotero/oauthwizard.cpp
++++ b/src/networking/zotero/oauthwizard.cpp
+@@ -35,7 +35,7 @@
+ #include "internalnetworkaccessmanager.h"
+ #include "logging_networking.h"
+
+-#include <QtOAuth>
++#include <QtOAuth/QtOAuth>
+
+ using namespace Zotero;
+
diff --git a/app-text/kbibtex/kbibtex-9999.ebuild b/app-text/kbibtex/kbibtex-9999.ebuild
index 6506817e9b..68e60bbc9f 100644
--- a/app-text/kbibtex/kbibtex-9999.ebuild
+++ b/app-text/kbibtex/kbibtex-9999.ebuild
@@ -61,10 +61,7 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${P/_/-}"
-PATCHES=(
- "${FILESDIR}/${PN}-revert-removing-qtoauth.patch"
- "${FILESDIR}/${PN}-part-revert-reenable-qtoauth.patch"
-)
+PATCHES=( "${FILESDIR}/${PN}-system-qtoauth.patch" )
src_prepare() {
kde5_src_prepare