aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-05-17 19:12:30 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2014-05-17 19:12:30 +0400
commit2eab01ce2be4dbfa91738421dc72bf432ad0aac9 (patch)
tree82ab788a6bdfb9007cb951bba56d60f80389209a /app-text
parent[x11-libs/libkscreen2] Use correct repo. (diff)
downloadkde-2eab01ce2be4dbfa91738421dc72bf432ad0aac9.tar.gz
kde-2eab01ce2be4dbfa91738421dc72bf432ad0aac9.tar.bz2
kde-2eab01ce2be4dbfa91738421dc72bf432ad0aac9.zip
[app-text/poppler] Add qt5 support
Package-Manager: portage-2.2.10
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/poppler-0.26.0-r1.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
new file mode 100644
index 0000000000..41b2fbdcd4
--- /dev/null
+++ b/app-text/poppler/Manifest
@@ -0,0 +1 @@
+DIST poppler-0.26.0.tar.xz 1591180 SHA256 8547032fc8ff34ba5f47b47eddfe67d0f2ff0ffcdcf5d189f52dc516770c621f SHA512 a1f0177f4e0403cfe11cad9573bebafff4ceca69519610823dbab51a60f6f2722cd86d20c4f3d26b405027548fe8efecc7f90905a943592176306ecf7cc0ad1a WHIRLPOOL b177afc5869be3097d42f7787a0e54fc12650eda869da3f015f2d65f2958165eab9d5d6e3dc6e535cc841ca9b4ff5fd303ce1f4dc0de64750756b9e4ac1469ba
diff --git a/app-text/poppler/poppler-0.26.0-r1.ebuild b/app-text/poppler/poppler-0.26.0-r1.ebuild
new file mode 100644
index 0000000000..59e930f6c5
--- /dev/null
+++ b/app-text/poppler/poppler-0.26.0-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.26.0.ebuild,v 1.1 2014/04/27 13:08:38 dilfridge Exp $
+
+EAPI=5
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0/46"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg jpeg2k +lcms png qt4 qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-1.32.1 )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ png? ( media-libs/libpng:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( >=app-text/poppler-data-0.4.4 )
+"
+
+DOCS=(AUTHORS NEWS README README-XPDF TODO)
+
+PATCHES=( "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch" )
+
+src_configure() {
+ # this is needed for multilib, see bug 459394
+ local ft_libdir ft_includedir
+ ft_libdir="$($(tc-getPKG_CONFIG) freetype2 --variable=libdir)"
+ ft_includedir="$($(tc-getPKG_CONFIG) freetype2 --variable=includedir)"
+ export FREETYPE_DIR="${ft_libdir}:${ft_includedir%/include}"
+ einfo "Detected FreeType at ${FREETYPE_DIR}"
+
+ mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_XPDF_HEADERS=ON
+ $(cmake-utils_use_enable curl LIBCURL)
+ $(cmake-utils_use_enable cxx CPP)
+ $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with introspection GObjectIntrospection)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use_find_package qt5 Qt5Core)
+ $(cmake-utils_use_with tiff)
+ )
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use cairo && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}