aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-17 09:46:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-17 09:51:59 +0200
commit06e2630464c632bf0270c00bab62a5ff8d843846 (patch)
treedb649cbf7c49403eb57d4d4a43bd43a252467328 /dev-libs
parentnet-p2p/ktorrent: 21.07.80 version bump (diff)
downloadkde-06e2630464c632bf0270c00bab62a5ff8d843846.tar.gz
kde-06e2630464c632bf0270c00bab62a5ff8d843846.tar.bz2
kde-06e2630464c632bf0270c00bab62a5ff8d843846.zip
dev-libs/kopeninghours: 21.07.80 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-21.07.80.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
new file mode 100644
index 0000000000..a0db5e0cac
--- /dev/null
+++ b/dev-libs/kopeninghours/Manifest
@@ -0,0 +1 @@
+DIST kopeninghours-21.07.80.tar.xz 65332 BLAKE2B 39b84ab82fef807a98113137a7da76babc92476a310f3de5de50792fb44b8307e94fd63df64c97710c7d7e489d4fa37f2d2c8a235ef18fbd138d150687707813 SHA512 081f30b8d84c96c5dd77adba2a69ea06b8c0b6fdb07b9f380b7b4e0b3736c79bf8bdb4cdecf66e9ef89d65a163503c15afaf4415a7416c3e5d2b9fc83746868d
diff --git a/dev-libs/kopeninghours/kopeninghours-21.07.80.ebuild b/dev-libs/kopeninghours/kopeninghours-21.07.80.ebuild
new file mode 100644
index 0000000000..dbea23e7b0
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-21.07.80.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+PYTHON_COMPAT=( python3_{8,9} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-21.03.90-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}