aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-05 11:37:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-05 11:45:37 +0200
commit47d270f6631196df66da4dee74cfc5cd6c28eef2 (patch)
treeb47a90b435cf70f7bf6598bf8e71b2f23496fcfe /dev-libs
parentkde-frameworks/kapidox: EAPI-8 bump, python3_10 (diff)
downloadkde-47d270f6631196df66da4dee74cfc5cd6c28eef2.tar.gz
kde-47d270f6631196df66da4dee74cfc5cd6c28eef2.tar.bz2
kde-47d270f6631196df66da4dee74cfc5cd6c28eef2.zip
dev-libs/appstream: EAPI-8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/appstream/appstream-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-libs/appstream/appstream-9999.ebuild b/dev-libs/appstream/appstream-9999.ebuild
index 2bc89c8eec..3d01a9ad62 100644
--- a/dev-libs/appstream/appstream-9999.ebuild
+++ b/dev-libs/appstream/appstream-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson xdg-utils
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ximion/${PN}"
else
@@ -25,14 +25,6 @@ IUSE="apt +introspection qt5 test"
RESTRICT="!test? ( test )"
-BDEPEND="
- app-text/docbook-xml-dtd:4.5
- dev-libs/appstream-glib
- dev-util/itstool
- >=dev-util/meson-0.42.0
- >=sys-devel/gettext-0.19.8
- test? ( dev-qt/linguist-tools:5 )
-"
DEPEND="
dev-libs/glib:2
dev-libs/libxml2:2
@@ -45,6 +37,14 @@ DEPEND="
)
"
RDEPEND="${DEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=dev-util/meson-0.42.0
+ >=sys-devel/gettext-0.19.8
+ test? ( dev-qt/linguist-tools:5 )
+"
src_prepare() {
default