aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-17 09:39:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-17 09:51:19 +0200
commit9abe0f5e0cd5f7d91691098794d6fd35be247a4e (patch)
tree318da73017e26c9ecd2fac218f6a292d97ff666d /dev-libs
parentnet-p2p/ktorrent: 21.08.49.9999 version bump (diff)
downloadkde-9abe0f5e0cd5f7d91691098794d6fd35be247a4e.tar.gz
kde-9abe0f5e0cd5f7d91691098794d6fd35be247a4e.tar.bz2
kde-9abe0f5e0cd5f7d91691098794d6fd35be247a4e.zip
dev-libs/kopeninghours: 21.08.49.9999 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/kopeninghours-21.08.49.9999.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/kopeninghours-21.08.49.9999.ebuild b/dev-libs/kopeninghours/kopeninghours-21.08.49.9999.ebuild
new file mode 100644
index 0000000000..42547ce8d9
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-21.08.49.9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+PYTHON_COMPAT=( python3_{8,9} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS=""
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-21.03.90-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}