aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 08:40:26 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 08:57:25 +0200
commite7ed05beaf8093a8c99fbadca24e0a1a88f00e10 (patch)
treedf947eeb440a61738b65a14f3a97accfd49c0287 /dev-libs
parentnet-p2p/ktorrent: 21.08.0 version bump (diff)
downloadkde-e7ed05beaf8093a8c99fbadca24e0a1a88f00e10.tar.gz
kde-e7ed05beaf8093a8c99fbadca24e0a1a88f00e10.tar.bz2
kde-e7ed05beaf8093a8c99fbadca24e0a1a88f00e10.zip
dev-libs/kopeninghours: 21.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-21.08.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 52c61635ad..47ae68e68c 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-21.07.90.tar.xz 65324 BLAKE2B 2054fb1c1e0acb72f1bf22c5be4966d0d1e0548e63142b0b3a57105afcac7f2db5babc389e9080f0103b49b017f950a26d58fbfbd5a24e2f2b95f9ad45d546d5 SHA512 720467525caab0f28af1882db44f00479321ffa3a1ef0af39b24e51df0a26c306a6dbc7cd4897a6eafa7a43aa12617a70638281cb5d837f4bf00270b6b2ce418
+DIST kopeninghours-21.08.0.tar.xz 65696 BLAKE2B e6fe12eea2f3cab18e07d7c17277a932ad3f57e897e727b61d4740aea87699669bd04becfe9943dd72f562d50141abed30c6342ac7728e0d0b386075b0ac6309 SHA512 529c53ac47eaa629ad0927b7ab3b29c3d89ec8313434ff59c123d6eae62caf6bde1c243045b56ab19ae2b0b8c6bf021baf20f89a14ce82e2ff759642709f3bfe
diff --git a/dev-libs/kopeninghours/kopeninghours-21.08.0.ebuild b/dev-libs/kopeninghours/kopeninghours-21.08.0.ebuild
new file mode 100644
index 0000000000..bf5b510bc6
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-21.08.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+PYTHON_COMPAT=( python3_{8,9} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-21.03.90-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}