aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 22:06:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 22:09:11 +0200
commit386c6eb5d355359444704e1354654539f942698e (patch)
tree379853b9cf70fb0af6a1b12188398f9ff34cb3af /kde-frameworks/kcompletion
parentkde-frameworks/kauth: 5.81.0 version bump (diff)
downloadkde-386c6eb5d355359444704e1354654539f942698e.tar.gz
kde-386c6eb5d355359444704e1354654539f942698e.tar.bz2
kde-386c6eb5d355359444704e1354654539f942698e.zip
kde-frameworks/kcompletion: 5.81.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
new file mode 100644
index 0000000000..cb815ce094
--- /dev/null
+++ b/kde-frameworks/kcompletion/Manifest
@@ -0,0 +1 @@
+DIST kcompletion-5.81.0.tar.xz 121996 BLAKE2B 998397f4c10f965d34d9fa0f44b38dd02b5a276c81a1a917b6604b09479e84e7c1806f57ed2a22fe4bd848bf75a9eb4d7d8f48a4645dea2be551c7a84666047f SHA512 ee12c7bc0deb9e3a3bdd0e138c4ffb7c5d04360581b8cf0e3741d2d7e6a60ae840918c0488d5ee50ec3c01f55963ee2c943e17b24ecec89649100bac7ffb2ce9
diff --git a/kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild
new file mode 100644
index 0000000000..a0fa08fde4
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.81.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}