aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-07 22:12:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-07 22:12:31 +0100
commit73972808cc5330f5254981448f26965e615c2666 (patch)
tree1a1b03dca3dcf8737a23ffd8df8f9c96a01c45dc /kde-frameworks/kcompletion
parentkde-frameworks/kauth: 5.76.0 version bump (diff)
downloadkde-73972808cc5330f5254981448f26965e615c2666.tar.gz
kde-73972808cc5330f5254981448f26965e615c2666.tar.bz2
kde-73972808cc5330f5254981448f26965e615c2666.zip
kde-frameworks/kcompletion: 5.76.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
new file mode 100644
index 0000000000..11af9166cd
--- /dev/null
+++ b/kde-frameworks/kcompletion/Manifest
@@ -0,0 +1 @@
+DIST kcompletion-5.76.0.tar.xz 121464 BLAKE2B 458bb01686846287bb9d3ac41db08bda1dcc159786bcbdabdad057408970ae2aa74f9b26023e58db6b1e5b079f1b82465f224efd2d90be9ba013c4ecbf16154b SHA512 96d11749bd972109b9c635a7664d205515caf7a3426b26006659e6bc32511fdb3d90f1ec91d1071d567e8ab96883bddd16cf303401b94c1ab72cd9c658040f6e
diff --git a/kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild
new file mode 100644
index 0000000000..280b3ee0bc
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.76.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}