aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-01 18:13:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-02 21:12:50 +0200
commitc0203fb8f45cdbd328011c10095b9237a9081213 (patch)
tree6343655d0eed04dd4ea302317c5e344c7ef18210 /kde-frameworks/kcompletion
parentkde-frameworks/kauth: 5.82.0 version bump (diff)
downloadkde-c0203fb8f45cdbd328011c10095b9237a9081213.tar.gz
kde-c0203fb8f45cdbd328011c10095b9237a9081213.tar.bz2
kde-c0203fb8f45cdbd328011c10095b9237a9081213.zip
kde-frameworks/kcompletion: 5.82.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.82.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
new file mode 100644
index 0000000000..1ac4446241
--- /dev/null
+++ b/kde-frameworks/kcompletion/Manifest
@@ -0,0 +1 @@
+DIST kcompletion-5.82.0.tar.xz 122088 BLAKE2B ce534393489d6ab980d3c093ef39b3d2341734e147231e6f22c5316091bafd40ef343432128926ec18e25ec8d3843018fa582bd2dc7475bb3c260e42452cc949 SHA512 19b76a46d09005ed5ab5b66ca48403f4bb0baade2b2f937ad6afdf5ef92adf7c94330502adc3aae29bb88fc5848469580319cbf4bba4bfa128537f4541fd9d24
diff --git a/kde-frameworks/kcompletion/kcompletion-5.82.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.82.0.ebuild
new file mode 100644
index 0000000000..a0fa08fde4
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.82.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}