aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 14:15:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-06 14:15:25 +0200
commit1ae69b2c16521da037661172822f5dae64f78bc3 (patch)
tree7ad382fce4f3bfd4eeaf57b56529537e64196806 /kde-frameworks/knewstuff
parentkde-frameworks/kio: 5.85.0 version bump (diff)
downloadkde-1ae69b2c16521da037661172822f5dae64f78bc3.tar.gz
kde-1ae69b2c16521da037661172822f5dae64f78bc3.tar.bz2
kde-1ae69b2c16521da037661172822f5dae64f78bc3.zip
kde-frameworks/knewstuff: 5.85.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/knewstuff')
-rw-r--r--kde-frameworks/knewstuff/Manifest1
-rw-r--r--kde-frameworks/knewstuff/knewstuff-5.85.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-frameworks/knewstuff/Manifest b/kde-frameworks/knewstuff/Manifest
new file mode 100644
index 0000000000..3e5e67ccb9
--- /dev/null
+++ b/kde-frameworks/knewstuff/Manifest
@@ -0,0 +1 @@
+DIST knewstuff-5.85.0.tar.xz 1138788 BLAKE2B 6f037ddd3dd7d9499d19b8d10b2486ced1ab169180d69a004369158665eb098015c60fd657e9d84af7b15634a28abd13e761b2728861f3f88c02ac0510121c5c SHA512 2da81b520ecab1d43b79e75ec56cbba410bd0944b13ea53eeee5ca94c77f9c04ad91a35b0c1942516edc5101a365f2a91b774405183bc8bf82c6cd5fb53a0570
diff --git a/kde-frameworks/knewstuff/knewstuff-5.85.0.ebuild b/kde-frameworks/knewstuff/knewstuff-5.85.0.ebuild
new file mode 100644
index 0000000000..569b0c3b16
--- /dev/null
+++ b/kde-frameworks/knewstuff/knewstuff-5.85.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for downloading and sharing additional application data"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="opds"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/attica-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ opds? ( =kde-frameworks/syndication-${PVCUT}*:5 )
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${PVCUT}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package opds KF5Syndication)
+ )
+
+ ecm_src_configure
+}