aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-07 12:42:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-07 12:50:48 +0100
commit2b928c644d4023603567ae78e23312ac6f5c1f5c (patch)
tree65e20df133cddab5854154ec46771daa620d1ece /kde-frameworks/purpose
parentkde-frameworks/kxmlgui: 5.114.0 version bump (diff)
downloadkde-2b928c644d4023603567ae78e23312ac6f5c1f5c.tar.gz
kde-2b928c644d4023603567ae78e23312ac6f5c1f5c.tar.bz2
kde-2b928c644d4023603567ae78e23312ac6f5c1f5c.zip
kde-frameworks/purpose: 5.114.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.114.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..95d3cc945e
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-5.114.0.tar.xz 179776 BLAKE2B 19cbc2744ef9e40a53aef90da9511c9d7a342f35b95e3ff0c8a090fdbaa84c44de94c71ff81c8d40e05dfbf52191d3a9440c54c3e1a12f6f11391d693fbfac81 SHA512 f56be72e5690da06e35cf339b9d45030f651cf1312a7e1ced850dcc137b06f5227533fa1276e4458fac22d3ff8ffef61d503732ce95957e9ea98cdac6916120f
diff --git a/kde-frameworks/purpose/purpose-5.114.0.ebuild b/kde-frameworks/purpose/purpose-5.114.0.ebuild
new file mode 100644
index 0000000000..4e19398996
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.114.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts kf6compat"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ || (
+ kde-apps/kaccounts-integration:6[qt5]
+ kde-apps/kaccounts-integration:5
+ )
+ >=net-libs/accounts-qt-1.16-r1[qt5(-)]
+ )
+"
+RDEPEND="${DEPEND}
+ kf6compat? ( kde-frameworks/purpose:6 )
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( >=net-libs/accounts-qml-0.7-r3[qt5(-)] )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ if use kf6compat; then
+ rm "${D}"/usr/share/icons/hicolor/128x128/apps/{reviewboard,phabricator}-purpose.png \
+ "${D}"/usr/share/icons/hicolor/16x16/apps/{reviewboard,phabricator}-purpose.png \
+ || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}