aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-07 00:00:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-07 00:15:39 +0200
commit53f96fcc962eae1b88e917ebe08f5edd336bcf57 (patch)
treebf6f868c3b499e886e2e8045d9f09e573db0ba45 /kde-frameworks/purpose
parentkde.org.eclass: kde-frameworks/kxmlrpcclient moved to portingAids (diff)
downloadkde-53f96fcc962eae1b88e917ebe08f5edd336bcf57.tar.gz
kde-53f96fcc962eae1b88e917ebe08f5edd336bcf57.tar.bz2
kde-53f96fcc962eae1b88e917ebe08f5edd336bcf57.zip
kde-frameworks: Add KDE Frameworks 5.71.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.71.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..fcd91eb734
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-5.71.0.tar.xz 155348 BLAKE2B 29ab7157e02d9e4888a9bec9153ea4b41fc48b6c515294c10c06c02d880ec4e51a85cd62cccb611b188c56d7f1b3aed922755222d6167043d99e352e22f0fd25 SHA512 f38d713f4c8253fc5cbe54572a1c574704d87fafd4b371210c3fb0e6f8d1c016669d46f0eb99aa596a760092b4e1b11c7e3d5ecae69cb9a0bdaa74a871b1564d
diff --git a/kde-frameworks/purpose/purpose-5.71.0.ebuild b/kde-frameworks/purpose/purpose-5.71.0.ebuild
new file mode 100644
index 0000000000..27625e1f89
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.71.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.1
+inherit ecm kde.org
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="+dolphin +kaccounts"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ dolphin? ( =kde-frameworks/knotifications-${PVCUT}*:5 )
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package dolphin KF5Notifications)
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst(){
+ ecm_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}