aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-04 13:46:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-04 13:46:27 +0100
commit7391f696b6fe79124b83b5e12298d92a3eb1bf05 (patch)
tree44ee7a16cd67cbf41d9c067b2ccbb6d22cf8814d /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.104.0 version bump (diff)
downloadkde-7391f696b6fe79124b83b5e12298d92a3eb1bf05.tar.gz
kde-7391f696b6fe79124b83b5e12298d92a3eb1bf05.tar.bz2
kde-7391f696b6fe79124b83b5e12298d92a3eb1bf05.zip
kde-frameworks/purpose: 5.104.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.104.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..28691c1cad
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-5.104.0.tar.xz 177424 BLAKE2B 790cffe2765bc1cca1f060bfe7faafa9c9c6e2ea211cf2b8ec912040a8813433896d52b35adcdc6a961ab2f1a67f7d251854f8c3007c6f1dd2f8c1f74cec729e SHA512 303640b2bae5c0bdd373881d06350ac05edb9dcfca0d0baa155a93fd98f4dadf2467254c46ba55508deaec21ca78d1ad458874b98d3bfd53856844cf3f13a3fa
diff --git a/kde-frameworks/purpose/purpose-5.104.0.ebuild b/kde-frameworks/purpose/purpose-5.104.0.ebuild
new file mode 100644
index 0000000000..166c267df1
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.104.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}