aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 22:11:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 22:17:40 +0100
commita6ba0b8a675ced5327a63ce68a3056e531a5c8a5 (patch)
treea7f2aae218cf4ab711463c301789800d93afaae9 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.78.0 version bump (diff)
downloadkde-a6ba0b8a675ced5327a63ce68a3056e531a5c8a5.tar.gz
kde-a6ba0b8a675ced5327a63ce68a3056e531a5c8a5.tar.bz2
kde-a6ba0b8a675ced5327a63ce68a3056e531a5c8a5.zip
kde-frameworks/purpose: 5.78.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.78.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..d3b3a39c1c
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-5.78.0.tar.xz 158484 BLAKE2B 4e0873c6e37b8eab75bfa487649bcc45731ad443eda84c637a46a8fa8bab14f71e2abc396d7ccce26ff1901e660f5aa3f5217954ad83264d44948fda37821f72 SHA512 793540ecb069ab89f685eb8a37509f547d3de6e84e8e56f9fb5b3f19f307f527f9e9141188f8a5a4f1ec2d10a9f2cdebe99440561797a35146e78b956b4db881
diff --git a/kde-frameworks/purpose/purpose-5.78.0.ebuild b/kde-frameworks/purpose/purpose-5.78.0.ebuild
new file mode 100644
index 0000000000..c03ada7bf4
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.78.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth +dolphin +kaccounts"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ dolphin? ( =kde-frameworks/knotifications-${PVCUT}*:5 )
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_prepare() {
+ ecm_src_prepare
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package dolphin KF5Notifications)
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}