aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 14:25:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 14:34:37 +0200
commitf28cb0a359af1706e5a05102ec951c85d00fd56f (patch)
tree3095e8bdc14364d046cf9578adfe880e16934f5c /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.83.0 version bump (diff)
downloadkde-f28cb0a359af1706e5a05102ec951c85d00fd56f.tar.gz
kde-f28cb0a359af1706e5a05102ec951c85d00fd56f.tar.bz2
kde-f28cb0a359af1706e5a05102ec951c85d00fd56f.zip
kde-frameworks/purpose: 5.83.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.83.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..a9bf531c73
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-5.83.0.tar.xz 159896 BLAKE2B db631013b796163d05935374e80829bce68b6a626570a8e5bbb805169dbf1a2a84ec95f34117db91dcf62b1d78d8a0d5162f9d34a94a03b3f333f29eb354b31f SHA512 3e7c562e5bf545fd766ab63dff6d4a91b587c83676582349a8a7a433f93898fa94ff53df57eae1746ddc5139124541d97edbcef71a28ed3215d5f0bd31f0c8ed
diff --git a/kde-frameworks/purpose/purpose-5.83.0.ebuild b/kde-frameworks/purpose/purpose-5.83.0.ebuild
new file mode 100644
index 0000000000..0dc933045f
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.83.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}