aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-03 21:17:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-04 21:42:06 +0200
commitdce663bd94c630741d716140463cf4aa77d38340 (patch)
treee96f9a103c148c1aeca2331346509c4a0a5a3802 /kde-frameworks
parentkde-frameworks/solid: 5.84.0 version bump (diff)
downloadkde-dce663bd94c630741d716140463cf4aa77d38340.tar.gz
kde-dce663bd94c630741d716140463cf4aa77d38340.tar.bz2
kde-dce663bd94c630741d716140463cf4aa77d38340.zip
kde-frameworks/sonnet: 5.84.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.84.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
new file mode 100644
index 0000000000..a9f1b47a76
--- /dev/null
+++ b/kde-frameworks/sonnet/Manifest
@@ -0,0 +1 @@
+DIST sonnet-5.84.0.tar.xz 295300 BLAKE2B bafd06d4b57841c4fa39e55235f12dbe447316f4e2af3b1b2dde3f9f6eb817a97a2298320447fbc0a2186ba50e5cd6bd62e77a5828087b65b6097961babaa7af SHA512 49021de3684d899b20b2ba8f980a701e3f467b0a9f76935fc38c347881a371bb0c51f924d44fc819f86119589df1391427365aabd92c1eebbd66f8d46bdf901d
diff --git a/kde-frameworks/sonnet/sonnet-5.84.0.ebuild b/kde-frameworks/sonnet/sonnet-5.84.0.ebuild
new file mode 100644
index 0000000000..c2df24e9d6
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.84.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # sonnet-test_settings: bug 680032
+ # sonnet-test_autodetect: bug 779994
+ local myctestargs=(
+ -E "(sonnet-test_autodetect|sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}