aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-19 17:29:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-19 17:29:23 +0200
commit393bc5b846771c6c72373a341aba40ce8efc9a18 (patch)
treeb234bd4cca61e7d261fc61473e510e1bc9e08a59 /kde-plasma/kde-gtk-config/kde-gtk-config-5.13.1.ebuild
parentprofiles: Add kde-plasma-5.13.1 package.mask (diff)
downloadkde-393bc5b846771c6c72373a341aba40ce8efc9a18.tar.gz
kde-393bc5b846771c6c72373a341aba40ce8efc9a18.tar.bz2
kde-393bc5b846771c6c72373a341aba40ce8efc9a18.zip
kde-plasma: Add KDE Plasma 5.13.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-plasma/kde-gtk-config/kde-gtk-config-5.13.1.ebuild')
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-5.13.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-5.13.1.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-5.13.1.ebuild
new file mode 100644
index 0000000000..13b77b96dd
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-5.13.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Plasma systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="https://cgit.kde.org/kde-gtk-config.git"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/glib:2
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/kde-gtk-config:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+}