aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-31 15:00:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-31 17:40:47 +0200
commite88fc56f50ba794948156fc3991a7b87abaf0874 (patch)
treecdf39f73e2d09fa930f4f1b37d576cb3afdcda22 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 5.22.5 version bump (diff)
downloadkde-e88fc56f50ba794948156fc3991a7b87abaf0874.tar.gz
kde-e88fc56f50ba794948156fc3991a7b87abaf0874.tar.bz2
kde-e88fc56f50ba794948156fc3991a7b87abaf0874.zip
kde-plasma/kwallet-pam: 5.22.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
new file mode 100644
index 0000000000..521865f9f8
--- /dev/null
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -0,0 +1 @@
+DIST kwallet-pam-5.22.5.tar.xz 19960 BLAKE2B 978860fc113e2a02bd2543aa5147832050fb3b53a1916939cc21772e98a7a2e4d47892d514427f15a3fbff70a6eadcb98fdd934fb8d731992ff3fc8252c32f6b SHA512 230135ee7aadbbc9f08695afa87fd7d8f0e3dca5da40f94bea92ad83a8a2ccc86efb7d593730079a0affc91f28383d089a08fd2b4db57961ba7c5b3a009a6038
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild
new file mode 100644
index 0000000000..2db13f66ab
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.22.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}