aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-21 22:29:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-22 10:56:09 +0100
commit8bea37d43bd77485ba4e53a2911d149ed4b7a7b2 (patch)
tree6adf1585b62bd11f2521cc04770f23e86dfbfaa6 /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 6.0.0 version bump (diff)
downloadkde-8bea37d43bd77485ba4e53a2911d149ed4b7a7b2.tar.gz
kde-8bea37d43bd77485ba4e53a2911d149ed4b7a7b2.tar.bz2
kde-8bea37d43bd77485ba4e53a2911d149ed4b7a7b2.zip
kde-plasma/plasma-firewall: 6.0.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-6.0.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
new file mode 100644
index 0000000000..77a927508c
--- /dev/null
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -0,0 +1 @@
+DIST plasma-firewall-6.0.0.tar.xz 367816 BLAKE2B 7e963187401722e27822760e1610fc04396febb96fcfd915d90a7ffea98c7d6ad41a753f749ff2abdb91141ed0871fc71e7f4b1d0d17cfa79eaff35af96076d5 SHA512 446283ef553498430858bf509e3b585517d69b71e66aedab3cf8963863668bc82cc90407c90b918e4aa961eac4e361bd8cd0070049d204aa41d7e988df7bdacb
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-6.0.0.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-6.0.0.ebuild
new file mode 100644
index 0000000000..b32a35aa77
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-6.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{10..12} )
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}