aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-20 16:56:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-22 22:26:45 +0200
commit8c9ef871adcaeb21842bc53d4ceacefae143fe60 (patch)
tree68918712cf29d7e6c243dbbb5fcfbcd7e0f577a5 /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 5.27.6 version bump (diff)
downloadkde-8c9ef871adcaeb21842bc53d4ceacefae143fe60.tar.gz
kde-8c9ef871adcaeb21842bc53d4ceacefae143fe60.tar.bz2
kde-8c9ef871adcaeb21842bc53d4ceacefae143fe60.zip
kde-plasma/plasma-firewall: 5.27.6 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.27.6.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
new file mode 100644
index 0000000000..a4c596d4fb
--- /dev/null
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -0,0 +1 @@
+DIST plasma-firewall-5.27.6.tar.xz 363172 BLAKE2B a999196d3680c959615c09989475312f855f58ce27054627c03daa289369ee12db2754740113e0c0330ddf5096ac12adec03b42003488c7213e0516d07c0dded SHA512 93ba3a0aab403df2174892962cb68c55da6c5ed14bbac1c6de939fdae3077d700e05688f29f16f59107b9b0dccd8d75808c566a55e115bf151452a55a7ea2ca8
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.27.6.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.27.6.ebuild
new file mode 100644
index 0000000000..2fa7d8d9b1
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-5.27.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{10..11} )
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}