aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-03 21:03:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-03 21:03:31 +0100
commitc0b672436eacaa9a3542db07f60572557ba62e18 (patch)
tree644d4f4ebe7c90d36fcbf91a5cdf51924c5b039e /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 5.24.0 version bump (diff)
downloadkde-c0b672436eacaa9a3542db07f60572557ba62e18.tar.gz
kde-c0b672436eacaa9a3542db07f60572557ba62e18.tar.bz2
kde-c0b672436eacaa9a3542db07f60572557ba62e18.zip
kde-plasma/plasma-firewall: 5.24.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.24.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
new file mode 100644
index 0000000000..a2a05c417b
--- /dev/null
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -0,0 +1 @@
+DIST plasma-firewall-5.24.0.tar.xz 344992 BLAKE2B 593b8e1133b9c3e6778f3d95d87ee0c3dda9888ab3ab170f78ee1160207054b609933638c12ba88052c13f8204ce894201bf8a005364587cba509d6f0e04706f SHA512 6b07149dc4c2e20d901327ea8e99d85ddcddc006df3354ad57660280d54d1d8164e8862f145b2ca232e054c440602ba61fbe249cd0c29781fb2cc2c6adf7730c
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.24.0.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.24.0.ebuild
new file mode 100644
index 0000000000..5ac26b7e39
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-5.24.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+KFMIN=5.90.0
+QTMIN=5.15.2
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}