aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-28 21:36:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-28 23:52:18 +0100
commit854c3f8d6537eab2b7f5a5569e61acd5625ae75e (patch)
treeb254cc67845287aea2a6a321c95e7717f87f6fc8 /media-libs/phonon
parentkde-plasma/plasma-workspace: Restrict to <dev-libs/appstream-1[qt5] (diff)
downloadkde-854c3f8d6537eab2b7f5a5569e61acd5625ae75e.tar.gz
kde-854c3f8d6537eab2b7f5a5569e61acd5625ae75e.tar.bz2
kde-854c3f8d6537eab2b7f5a5569e61acd5625ae75e.zip
media-libs/phonon: add 4.12.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/phonon')
-rw-r--r--media-libs/phonon/Manifest1
-rw-r--r--media-libs/phonon/phonon-4.12.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/phonon/Manifest b/media-libs/phonon/Manifest
new file mode 100644
index 0000000000..65c5649321
--- /dev/null
+++ b/media-libs/phonon/Manifest
@@ -0,0 +1 @@
+DIST phonon-4.12.0.tar.xz 408996 BLAKE2B 568af4aec5247759e49db2137978b9f1828256f817bcb321f02e69d597d78e97c9ce437e89cd63b5a8b15c312f74ccee11b34270e74be2dc24c2af9ee97490f0 SHA512 0dbd88464985051f4c43e64a4d0b7e2d65e7f6b54fd2bae4ec1790fbdf9f79348aa91d4839c72a4f66297d5a9c7b379cc34923b99b97130a5443e5b2c0cc8a9a
diff --git a/media-libs/phonon/phonon-4.12.0.ebuild b/media-libs/phonon/phonon-4.12.0.ebuild
new file mode 100644
index 0000000000..63d504edbc
--- /dev/null
+++ b/media-libs/phonon/phonon-4.12.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop ecm kde.org
+
+DESCRIPTION="KDE multimedia abstraction library"
+HOMEPAGE="https://community.kde.org/Phonon"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/phonon/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) !pulseaudio? ( || ( GPL-2 GPL-3 ) )"
+SLOT="0"
+IUSE="designer pulseaudio +qt5 qt6 +vlc"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libpulse[glib]
+ )
+ qt5? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ designer? ( dev-qt/designer:5 )
+ )
+ qt6? (
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[gui,widgets]
+ designer? ( dev-qt/qttools:6[designer] )
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+ virtual/pkgconfig
+"
+PDEPEND="
+ vlc? ( >=media-libs/phonon-vlc-0.12.0[qt5?,qt6?] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPHONON_BUILD_DESIGNER_PLUGIN=$(usex designer)
+ -DCMAKE_DISABLE_FIND_PACKAGE_GLIB2=$(usex !pulseaudio)
+ -DCMAKE_DISABLE_FIND_PACKAGE_PulseAudio=$(usex !pulseaudio)
+ -DPHONON_BUILD_QT5=$(usex qt5)
+ -DPHONON_BUILD_QT6=$(usex qt6)
+ -DPHONON_BUILD_SETTINGS=ON
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ make_desktop_entry "${PN}settings" \
+ "Phonon Audio and Video" preferences-desktop-sound
+}