aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-26 03:10:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-26 03:15:01 +0200
commit960ae9fa16b24891520a73b1a72fa98c23389ded (patch)
tree03d1acb5ec2202d6c833fbafd26fc20f1fbc2f29 /media-libs/phonon
parentkde-apps/mailcommon: Fix DEPENDs (diff)
downloadkde-960ae9fa16b24891520a73b1a72fa98c23389ded.tar.gz
kde-960ae9fa16b24891520a73b1a72fa98c23389ded.tar.bz2
kde-960ae9fa16b24891520a73b1a72fa98c23389ded.zip
media-libs/phonon: Install desktop entry if USE !pulseaudio, drop USE gui
In Plasma 5.17, the KCM in use up to now is going to be removed. Phonon provides phononsettings as replacement with familiar UI, but regards it as redundant for PA users. Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/phonon')
-rw-r--r--media-libs/phonon/phonon-9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/media-libs/phonon/phonon-9999.ebuild b/media-libs/phonon/phonon-9999.ebuild
index 9c9a4fc940..6edaf832b5 100644
--- a/media-libs/phonon/phonon-9999.ebuild
+++ b/media-libs/phonon/phonon-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit kde5
+inherit desktop kde5
DESCRIPTION="KDE multimedia abstraction library"
HOMEPAGE="https://phonon.kde.org/"
@@ -15,7 +15,7 @@ fi
LICENSE="|| ( LGPL-2.1 LGPL-3 )"
SLOT="0"
-IUSE="debug designer gstreamer gui pulseaudio +vlc"
+IUSE="debug designer gstreamer pulseaudio +vlc"
BDEPEND="
dev-qt/linguist-tools:5
@@ -42,7 +42,14 @@ src_configure() {
-DPHONON_BUILD_DESIGNER_PLUGIN=$(usex designer)
-DCMAKE_DISABLE_FIND_PACKAGE_GLIB2=$(usex !pulseaudio)
-DCMAKE_DISABLE_FIND_PACKAGE_PulseAudio=$(usex !pulseaudio)
- -DPHONON_BUILD_SETTINGS=$(usex gui)
+ -DPHONON_BUILD_SETTINGS=$(usex !pulseaudio)
)
kde5_src_configure
}
+
+src_install() {
+ kde5_src_install
+ use pulseaudio || \
+ make_desktop_entry "${PN}settings" \
+ "Phonon Audio and Video" preferences-desktop-sound
+}