aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation/maintainers/bump-from-set.sh')
-rwxr-xr-xDocumentation/maintainers/bump-from-set.sh9
1 files changed, 5 insertions, 4 deletions
diff --git a/Documentation/maintainers/bump-from-set.sh b/Documentation/maintainers/bump-from-set.sh
index ff32141971..199af2abff 100755
--- a/Documentation/maintainers/bump-from-set.sh
+++ b/Documentation/maintainers/bump-from-set.sh
@@ -15,8 +15,11 @@ get_package_list_from_set() {
get_main_tree_keyword() {
local portdir="$(portageq get_repo_path / gentoo)"
local cp="${1}"
-
- echo $(sed -ne 's/^KEYWORDS="\(.*\)"/\1/p' "$(ls ${portdir}/${cp}/*.ebuild | sort | tail -n 1)")
+ if [[ -e ${portdir}/${cp} ]] ; then
+ echo $(sed -ne 's/^KEYWORDS="\(.*\)"/\1/p' "$(ls ${portdir}/${cp}/*.ebuild | sort | tail -n 1)")
+ else
+ echo "~amd64 ~x86"
+ fi
}
help() {
@@ -28,8 +31,6 @@ help() {
echo
echo Reads PORTDIR from your enviroment, defaulting to the current directory.
echo
- echo Reads KEYWORDS for the new ebuild from your environment, defaulting to ~amd64.
- echo
echo Usage: bump-from-set.sh SETNAME SOURCEVERSION DESTINATIONVERSION
echo Example: bump-from-set.sh kde-plasma-5.7 5.7.49.9999 5.7.1
exit 0