aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/calligra/calligra-9999.ebuild')
-rw-r--r--app-office/calligra/calligra-9999.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/app-office/calligra/calligra-9999.ebuild b/app-office/calligra/calligra-9999.ebuild
index c8bdc8cb76..1c65c68094 100644
--- a/app-office/calligra/calligra-9999.ebuild
+++ b/app-office/calligra/calligra-9999.ebuild
@@ -1,13 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-if [[ ${KDE_BUILD_TYPE} == release ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
CHECKREQS_DISK_BUILD="4G"
KDE_HANDBOOK="forceoptional"
KDE_TEST="forceoptional"
@@ -16,6 +11,11 @@ inherit check-reqs kde5
DESCRIPTION="KDE Office Suite"
HOMEPAGE="https://www.calligra.org/"
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
CAL_FTS=( karbon sheets words )
LICENSE="GPL-2"
@@ -96,7 +96,6 @@ COMMON_DEPEND="
x11-libs/libX11
)
calligra_experimental_features_stage? (
- $(add_qt_dep qtwebkit)
okular? ( $(add_kdeapps_dep okular) )
)
calligra_features_sheets? (
@@ -144,11 +143,6 @@ src_prepare() {
punt_bogus_dep Qt5 Declarative
punt_bogus_dep Qt5 OpenGL
- if ! use calligra_experimental_features_stage; then
- punt_bogus_dep Qt5 WebKitWidgets
- punt_bogus_dep Qt5 WebKit
- fi
-
# Hack around the excessive use of CMake macros
if use okular && ! use calligra_features_words; then
sed -i -e "/add_subdirectory( *okularodtgenerator *)/ s/^/#DONT/" \