aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdebase-data/kdebase-data-4.14.2.ebuild')
-rw-r--r--kde-base/kdebase-data/kdebase-data-4.14.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdebase-data/kdebase-data-4.14.2.ebuild b/kde-base/kdebase-data/kdebase-data-4.14.2.ebuild
new file mode 100644
index 0000000000..7677c57187
--- /dev/null
+++ b/kde-base/kdebase-data/kdebase-data-4.14.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase"
+IUSE="+wallpapers"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ wallpapers? ( $(add_kdebase_dep kde-wallpapers) )
+ $(add_kdebase_dep oxygen-icons)
+ x11-themes/hicolor-icon-theme
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}