aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/qyoto/qyoto-4.14.2.ebuild')
-rw-r--r--kde-base/qyoto/qyoto-4.14.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/qyoto/qyoto-4.14.2.ebuild b/kde-base/qyoto/qyoto-4.14.2.ebuild
new file mode 100644
index 0000000000..d53e733bf2
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.14.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}