aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/step/step-4.14.2.ebuild')
-rw-r--r--kde-base/step/step-4.14.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-base/step/step-4.14.2.ebuild b/kde-base/step/step-4.14.2.ebuild
new file mode 100644
index 0000000000..089e6bbc0e
--- /dev/null
+++ b/kde-base/step/step-4.14.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="The KDE physics simulator"
+HOMEPAGE="http://edu.kde.org/step"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+ kde4-base_src_configure
+}